В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Verra990
Verra990
11.07.2021 01:19 •  Информатика

Программа на с++ напишите программу, которая вводит четыре натуральных числа (a, b, c и d) и находит все пятизначные числа, которые при делении на a в остатке b , а при делении на c в остатке d . входные данные первая входная строка содержит два натуральных числа, разделённые пробелами: a и b. вторая строка содержит натуральные числа c и d, также разделённые пробелом. гарантируется, что 0 ≤ b ≤ a и 0 ≤ d ≤ c. выходные данные программа должна вывести в одну строчку через пробел все пятизначные натуральные числа, которые при делении на a в остатке b, а при делении на c в остатке d . если таких чисел нет, программа должна вывести число -1.

Показать ответ
Ответ:
Vasya1337ez
Vasya1337ez
06.10.2020 23:55
#include <iostream>
using namespace std;

int main(){
int a,b,c,d,o=0;
cin>>a>>b>>c>>d;
for (int i=10000; i<=99999;i++)
  if (i % a ==b && i % c == d)
  {
        cout<<i<<' ';
  o=1;
  }
if (o==0)
    cout<<-1;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота