В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Элизия12
Элизия12
19.10.2020 09:12 •  Информатика

PROGRAM Z1; Образец
VAR A, H: INTEGER;
S: REAL;
BEGIN
WRITELN (‘ВВЕДИ ОСНОВАНИЕ ТРЕУГОЛЬНИКА’);
READLN (A);
WRITELN (‘ВВЕДИ ВЫСОТУ ТРЕУГОЛЬНИКА’);
READLN (H);
S:=A*H/2;
WRITE (‘ПЛОЩАДЬ ТРЕУГОЛЬНИКА РАВНА ‘, S);
END.
Составьте программы, которые позволят решать задачи:
1) Вычислить периметр треугольника
Переменные:
А, В, С – стороны треугольника (целые числа)
P – периметр (целое число)
Входные данные Выходные данные
3
4
5
12
2) Вычислить периметр и площадь квадрата
Переменные:
А - сторона квадрата (целые числа)
P – периметр квадрата (целое число)
S – площадь квадрата (целое число)
Входные данные Выходные данные
3 12
9
3) Вычислить площадь трапеции
Переменные:
А, В – основания трапеции (целые числа)
H – высота трапеции (целое число)
S – площадь трапеции (вещественное число)
Входные данные Выходные данные
10
7
4
34

Показать ответ
Ответ:
Bigdaddypro100
Bigdaddypro100
27.09.2021 09:13

ответ:Внутри условных инструкций можно использовать любые инструкции языка Питон, в том числе и условную инструкцию. Получаем вложенное ветвление – после одной развилки в ходе исполнения программы появляется другая развилка. При этом вложенные блоки имеют больший размер отступа (например, 8 пробелов). Покажем это на примере программы, которая по данным ненулевым числам x и y определяет, в какой из четвертей координатной плоскости находится точка (x,y):

x = int(input())

y = int(input())

if x > 0:

   if y > 0:               # x>0, y>0

       print("Первая четверть")

   else:                   # x>0, y<0

       print("Четвертая четверть")

else:

   if y > 0:               # x<0, y>0

       print("Вторая четверть")

   else:                   # x<0, y<0

       print("Третья четверть")

В этом примере мы использовали комментарии – текст, который интерпретатор игнорирует. Комментариями в Питоне является символ # и весь текст после этого символа до конца строки.

Объяснение:В этом примере мы использовали комментарии – текст, который интерпретатор игнорирует. Комментариями в Питоне является символ # и весь текст после этого символа до конца строки.

0,0(0 оценок)
Ответ:
tatyanamazur90
tatyanamazur90
05.02.2022 15:43

1. Берілген нүктелер арқылы өтетін түзудің теңдеуін жазыңыз: А(2;1) В(-1;2). [2 ұпай]

2. Шеңбердің берілген теңдеуі бойынша оның центрінің координаталары мен радиусын табыңыз: (х-4)2 +(у+8)2 =36 [1 ұпай]

3. нүктелері берілген.

a) төбелерінің координаталары бойынша салыңыз; [1 ұпай]

b) қабырғаларының ұзындықтарын табыңыз; [3 ұпай]

c) түрін анықтаңыз (теңқабырғалы, теңбүйірлі, тікбұрышты); [2 ұпай]

d) берілген үшбұрыштың ауданын есептеңіз. [2 ұпай]

4. Төбелері А (1;-1) В (0;1) С (4;3) және Д (5;1) нүктелері болатын төртбұрыштың тіктөртбұрыш болатынын дәлелдеп, оның ауданын табыңыз. Ол үшін:

a) төбелерінің координаталары бойынша сызбасын салыңыз; [1 ұпай]

b) қабырғаларының ұзындықтарын табыңыз; [4 ұпай]

c) диагональдарын анықтап, дәлелдеңіз; [2 ұпай]

d) тіктөртбұрыштың ауданын есептеңіз. [2 ұпай]

Объяснение

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота