В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
akovlevavika444
akovlevavika444
02.01.2022 12:59 •  Информатика

Практическая работа. Тема: «Различные варианты программирования циклических алгоритмов».
Вывести квадраты первых десяти натуральных чисел.
1) Найти сумму 1 + 1/3 + 1/5 +...(N слагаемых).
2) Найти сумму ряда: S = x - x2 /4 + x3/9 - x4/16... (n слагаемых).

Показать ответ
Ответ:
66PrIvEt66666
66PrIvEt66666
21.08.2020 17:52
Var _500,_100,_50,_10,money_get:integer;beginwriteln('Введите стоимость товара');readln(money_get);while(money_get mod 10 <> 0) do        begin        writeln('стоимость должна делиться на 10, попробуйте еще раз');        readln(money_get);        end;while (money_get>=500) do        begin        _500:=_500+1;        money_get:=money_get-500;        end;while (money_get>=100) do        begin        _100:=_100+1;        money_get:=money_get-100;        end;while (money_get>=50) do        begin        _50:=_50+1;        money_get:=money_get-50;        end;while (money_get>=10) do        begin        _10:=_10+1;        money_get:=money_get-10;        end;
writeln(_500,': 500 рублей',_100,':100 рублей',_50,':50 рублей',_10,':10 рублей');

readln;end.
0,0(0 оценок)
Ответ:
domaris246
domaris246
17.04.2021 17:14

Итак, целевой язык - C++. Это значит мы - радостные обладатели технологии потоков, с коей мы будем производить весь ввод/вывод как при работе с файлами, так и при работе со стандартным вводом/выводом (консолью).

Ну а раз уж мы работаем с потоками, то будем делать это красивенько: создадим класс-обёртку для потока ввода, цель которого - поиск в этом потоке цитат и отправка их на поток вывода (который мы передаём).

[!] Стоит отметить, что по заданию не сказано, что есть разница между ' и ". Поэтому будем считать их одинаковыми.

[!] Внимание! Рядом с исполняемым файлом надо создать текстовый файл data.txt c текстом и цитатами.

Код

С++11

#include <iostream>#include <fstream>using std::cout;class QuotesFinder {    std::istream &in_stream;    bool is_it_in_quote = false;public:    QuotesFinder() = delete;    QuotesFinder(QuotesFinder&&) = default;    QuotesFinder(QuotesFinder const&) = default;    explicit QuotesFinder(std::istream &is) : in_stream(is) {}    [[nodiscard]]    bool eof() const {        return in_stream.eof();    }    // Вот тут происходит вся магия    QuotesFinder& operator >> (std::ostream& out_stream) {        char buffer;        in_stream.get(buffer); //Получаем очередной символ из потока        if (buffer == '\"' || buffer == '\'') {            if (is_it_in_quote) {                is_it_in_quote = false;                out_stream << buffer;                out_stream << "\n";                return *this;            }            is_it_in_quote = true;        }        if (is_it_in_quote) {            out_stream << buffer;        }        return *this;    }};int main() {    std::ifstream file("data.txt");  // Открываем файл    if (!file.is_open()) {        cout << "File is not exits!";        return 1;    }    QuotesFinder finder(file);  // Создаём обёртку из файлового потока    while (!finder.eof()) // Пока не достигли конца потока        finder >> cout; // переправляем очередной кусок информации в поток вывода}
Написать программу на С++. Задача - Считать текст из файла и вывести на экран только цитаты, т. е. п
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота