В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Асечка05
Асечка05
22.12.2020 02:00 •  Информатика

:практическая работа №3. ветвления уровень a. напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. пример: введите два числа: 1 5 наименьшее число 1 наибольшее число 5 уровень b. напишите программу, которая получает с клавиатуры четыре целых числа и находит наибольшее из них. пример: введите четыре числа: 1 2 5 3 наибольшее число 5 уровень c. напишите программу, которая получает с клавиатуры возрасты трёх человек (антона, бориса и виктора) и определяет, кто из них старше. пример: возраст антона: 15 возраст бориса: 17 возраст виктора: 16 ответ: борис старше всех. пример: возраст антона: 17 возраст бориса: 17 возраст виктора: 16 ответ: антон и борис старше виктора. на языке паскаль.

Показать ответ
Ответ:
anna18341
anna18341
08.10.2020 20:11
Program p1;
var a,b:integer;
begin
writeln ('Введите 2 числа');
readln (a,b);
if a=b then writeln ('Числа одинаковые')
else if a>b then
begin writeln ('Наибольшее число ',a);
writeln ('Наименьшее число ',b);
end
else begin writeln ('Наибольшее число ',b);
writeln ('Наиментшее число 10 ',a);
end;
end.

program p2;
var a,b,c,d:integer;
begin
writeln ('Введите 4 числа');
readln (a,b,c,d);
if a<b then a:=b;
if c<d then c:=d;
if a<c then a:=c;
writeln ('Наибольшее число ',a);
end.

program p3;
var a,b,v:integer;
begin
writeln ('Введите возрасты людей:');
write ('Антона - ');
readln (a);
write ('Бориса - ');
readln (b);
write ('Виктора - ');
readln (v);
if (a=b) and (a=v) then writeln ('Все люди одного возраста');
if (a=b) and (a>v) then writeln ('Антон и Борис старше Виктора');
if (a=b) and (a<v) then writeln ('Виктор старше всех')
else if (v>a) and (v>b) then writeln ('Виктор старше всех');
if (b=v) and (b>a) then writeln ('Борис и Виктор старше Антона');
if (b=v) and (b<a) then writeln ('Антон старше всех')
else if (a>v) and (a>b) then writeln ('Антон старше всех');
if (a=v) and (a>b) then writeln ('Антон и Виктор старше Бориса');
if (a=v) and (a<b) then writeln ('Борис старше всех')
else if (b>v) and (b>a) then writeln ('Борис старше всех');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота