Практическая работа № 3 Программирование обработки одномерных массивов Цель работы: Изучить типы массивов данных и приобрести навыки по обработке одномерных массивов с использованием языка программирования Pascal. Краткие теоретические сведения: Одномерный массив: Правила определения переменных типа массив. вариант 1: var {раздел описания переменных} : array [ 1.. ] of вариант 2: type (раздел описания типов) = array [ 1.. ] of ; var {раздел описания переменных} : ; обращение по индексу : [ ] ( пример - a[i] ) Оператор цикла с известным числом повторений : Общий вид простого оператора for: For to do Общий вид составного оператора for: For to do begin … end; при уменьшении значения переменной цикла вместо “ to ” используется “downto”
Задание : Составить программу обработки одномерного массива в соответствии с заданием. При составлении программы использовать два определения типа соответственно. Заменить отрицательные элементы массива R(10) значением 0 Контрольные вопросы: 1. Описание одномерного массива? 2. Применение раздела type для описания одномерных массивов? 3. Операция обращения по индексу для одномерного массива? 4. Статический и динамический организации массивов? 5. Какой оператор цикла наиболее предпочтительно использовать при обработке одномерных массивов?
Работа станков с ЧПУ (числовым программным управлением) осуществляется с систем числового программного управления – совокупности функционально взаимосвязанных и взаимодействующих технических и программных средств. Конструктивно системы ЧПУ различают разомкнутые, замкнутые и самонастраивающиеся. Разомкнутые системы ЧПУ используют один поток информации. Устройство считывает программу, после чего подает команды механизму, осуществляющему перемещение исполнительных элементов станка. СЧПУ замкнутого типа использует два потока информации. Один поток поступает от считывающего устройства, другой от устройства, измеряющего перемещения исполнительных элементов станка. Устройства самонастраивающихся СЧПУ имеют возможность корректировать информацию в зависимости от изменений, происходящих при обработке предыдущей заготовки. Самонастраивающиеся системы позволяют повысить точность обработки, так как изменения запоминаются в устройствах самонастройки памяти станка, после чего преобразуются в управляющий сигнал. Автоматическая при процесса обработки заготовки к изменяющимся условиям – важное свойство самонастраивающихся СЧПУ. Существует классификация систем числового программного управления по виду управления движением. СЧПУ бывают позиционными, прямоугольными и контурными. Позиционные системы – это системы, обеспечивающие точную установку исполнительного механизма в заданное положение. До начала процесса обработки выполняется установка исполнительного элемента в точке с заданными координатами, после этого начинается обработка. В отличие от позиционных систем прямоугольные системы обеспечивают последовательное включение продольной и поперечной подач станка при обработке поверхности ступенчатой формы. Данный вид СЧПУ используется в токарных, револьверных, фрезерных станках. Системы ЧПУ, обеспечивающие непрерывное управление рабочими элементами для получения необходимого контура обработки, называют контурными.
Объяснение:
using System;
namespace ConsoleApp2
{
class Program
{
static void Main(string[] args)
{
bool InArea = false;
Console.Write("R=");
double R = double.Parse(Console.ReadLine());
Console.Write("x=");
double x = double.Parse(Console.ReadLine());
Console.Write("y=");
double y = double.Parse(Console.ReadLine());
// Проверяем попадает ли в полукруг
if (x <= 0 && y >= 0 && x * x + y * y <= R * R) InArea = true;
// Проверяем попадает ли в первую половинку треугольника
// Уравнение прямой будет y=-2x
if (x > 0 && x <= R/2.0 && y >= -2*x && y<=0) InArea = true;
// Проверяем попадает ли во вторую половинку треугольника
// Уравнение прямой будет y=2x-2R
if (x > 0 && x <= R / 2.0 && y >= 2 * x - 2 * R && y <= 0) InArea = true;
if(InArea) Console.WriteLine("Точка принадлежит области");
else Console.WriteLine("Точка не принадлежит области");
Console.ReadLine();
}
}
}