Постройте и запишите в виде программы алгоритм вычисления суммы квадратов десяти произвольных чисел, вводимых с клавиатуры в процессе выполнения программы не на поскале.
Program D1KPxx18; uses crt; var x,y,a:real; label 1,2,3,4; begin 4:writeln('Выберите что вам нужно: 1-синус числа, 2-косинус числа, 3-выход'); read(a); if a=1 then goto 1; if a=2 then goto 2; if a=3 then goto 3; 1:begin writeln('Введите "х"'); read(x); y:=sin(x); writeln('Синус "х" равен ',y); writeln('Ещё? 1-No, 2-Yes'); read(a); if a=2 then goto 4 else goto 3; end; 2:begin writeln('Введите "х"'); read(x); y:=cos(x); writeln('Косинус "х" равен ',y); writeln('Ещё? 1-No, 2-Yes'); read(a); if a=2 then goto 4 else goto 3; end; 3:writeln('Пока!'); end.
Программа основана на метках, перемещая метки можно переходить к разным местам программы, тем самым использую их как меню... это если я правильно понял что именно значило:"Организовать меню")))
1) Называется системой команд исполнителя (СКИ) 2) Понятность Надо сказать, что алгоритм должен быть понятен не только автору, но и исполнителю. Если мы предложим исполнителю, например утюгу постирать одежду, то он никогда этого не сделает, потому, что не поймет, т. к. такой программы в нём не заложено. Или, например, если мы предложим какому-нибудь мальчику испечь торт то у него, как правило, ни чего не получится, потому что этого они делать не умеют. Но если мы составим подробный алгоритм работы, разобьем его на элементарные шаги, такие, что он без труда поймёт и сможет выполнить каждый шаг, то он сможет успешно испечь любой торт. Каждый шаг алгоритма обязательно представляет собой какое-либо допустимое действие исполнителя. Это свойство алгоритма называют понятностью.
uses crt;
var
x,y,a:real;
label 1,2,3,4;
begin
4:writeln('Выберите что вам нужно: 1-синус числа, 2-косинус числа, 3-выход');
read(a);
if a=1 then
goto 1;
if a=2 then
goto 2;
if a=3 then
goto 3;
1:begin
writeln('Введите "х"');
read(x);
y:=sin(x);
writeln('Синус "х" равен ',y);
writeln('Ещё? 1-No, 2-Yes');
read(a);
if a=2 then goto 4
else goto 3;
end;
2:begin
writeln('Введите "х"');
read(x);
y:=cos(x);
writeln('Косинус "х" равен ',y);
writeln('Ещё? 1-No, 2-Yes');
read(a);
if a=2 then goto 4
else goto 3;
end;
3:writeln('Пока!');
end.
Программа основана на метках, перемещая метки можно переходить к разным местам программы, тем самым использую их как меню... это если я правильно понял что именно значило:"Организовать меню")))
2)
Понятность
Надо сказать, что алгоритм должен быть понятен не только автору, но и исполнителю. Если мы предложим исполнителю, например утюгу постирать одежду, то он никогда этого не сделает, потому, что не поймет, т. к. такой программы в нём не заложено. Или, например, если мы предложим какому-нибудь мальчику испечь торт то у него, как правило, ни чего не получится, потому что этого они делать не умеют. Но если мы составим подробный алгоритм работы, разобьем его на элементарные шаги, такие, что он без труда поймёт и сможет выполнить каждый шаг, то он сможет успешно испечь любой торт. Каждый шаг алгоритма обязательно представляет собой какое-либо допустимое действие исполнителя. Это свойство алгоритма называют понятностью.