В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Михаил1946
Михаил1946
04.09.2020 19:52 •  Информатика

Пользователь вводит с клавиатуры число N. Программа выводит на экран три числа:
1) сумму всех чисел на промежутке от 1 до N;
2) произведение всех нечетных чисел на промежутке от 1 до N.
3) количество чисел, которые делятся нацело на 3 на промежутке от 1 до N.
Входные данные:
Одно целое число N.
Исходные данные:
Вывести три числа: 1) сумму всех чисел;
2) произведение нечетных чисел;
3) количество чисел, которые делятся на 3

Показать ответ
Ответ:
afashahbazova
afashahbazova
19.01.2021 18:25

N = int(input())

sums = 0

pr = 1

counter = 0

for i in range(1,N+1):

   sums += i

for i in range(1,N+1,2):

   pr *= i

for i in range(1,N+1):

   if i % 3 == 0:

       counter += 1

print(sums)

print(pr)

print(counter)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота