В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
lavlln
lavlln
30.09.2021 17:50 •  Информатика

Получив на вход число x, приведённая ниже программа выводит два числа — m и n. var x, m, n: integer;

begin

readln (x);

m:=0;

n:=0;

while x>0 do

begin

if n
m:=m+1;

x:=x div 10;

end;

writeln (m);

write (n)

end.

Известно, что при некотором значении x были выведены числа 3 и 7.

Укажите наибольшее и наименьшее из таких чисел x. В ответе запишите сначала наименьшее число, затем, без пробелов запятых или других дополнительных символов, наибольшее число

Показать ответ
Ответ:
АэлинкаМалинка
АэлинкаМалинка
24.12.2022 19:31
Обозначим P,Q,A утверждение что х принадлежит соответствующему отрезку
¬А отрицание А, то есть х не принадлежит А
перепишем и упростим исходную формулу
P→((Q∧¬A)→P)
известно что X→Y=¬X∨Y (доказывается просто, например через таблицу истинности)
тогда:
P→(¬(Q∧¬A)∨P)
раскроем скобку ¬(Q∧¬A) с закона де Моргана (стыдно их не знать, если что это такие же основы как и таблицы истинности)
P→(¬Q∨¬¬A∨P) = P→(¬Q∨A∨P) = ¬P∨¬Q∨A∨P
¬P∨P=1 то есть всегда истинно и 1∨Х=Х значит ¬P и P можно убрать
остается ¬Q∨A
Значит х либо принадлежит А либо не принадлежит Q
для выполнения этого условия необходимо чтобы все значения Q принадлежали А, тогда минимальное А совпадает с Q
ответ А=[40,77]
0,0(0 оценок)
Ответ:
Артём24532523
Артём24532523
06.11.2020 18:08

"Я самый главный!"- заявил монитор, на мне возникает информация и изображения.

"Нет, я самая главная,- сказала клавиатура, без меня никак, не сможешь ничего оттреадактировать,вбить информацию в память, общаться - да вообще ничего!"

Но память возразила : " Ээх вы, я тут главнее всех, как вы без меня! Ничего не сохранишь, не запомнишь, да в общем без меня очень сложно что-то представить!"

"Да вы что? - начал возмущаться процессор, - Главных не должно быть, мы все представляем собой одно целое!" Так они и воссоединились и представляют собой одну частичку главного . 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота