В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nikolsonr
nikolsonr
16.08.2021 08:37 •  Информатика

По языку паскаля, завтра уже сдать надо. 1) напишите программу, которая выводит код введенного пользователем символа. программа должна завершать свою работу в результате ввода, например точки. 2)напишите программу, которая выводит на экран первую часть таблицы кодировки символов (от 0 до 127). таблица должна состоять из восьми колонок и шестнадцати строк. в первой колонке должны быть символы с кодом от 0 до 15, во второй от 16 до 31 и т.д.

Показать ответ
Ответ:
InfoChan
InfoChan
21.07.2020 01:42
1 задача:
program znan1;
uses crt;
var a:char;
begin
clrscr;
readln(a);
while a<>'.' do
begin
writeln(ord(a));
readln(a);
end;
end.

2 задача:
program znan2;
uses crt;
var i,j:integer;
begin
for i:=1 to 16 do
begin
for j:=1 to 8 do
begin
write((i*j-1):5,'-',chr(i*j-1));
end;
writeln;
end;
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота