В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Bratok16
Bratok16
07.08.2021 11:50 •  Информатика

по программе бесик :Составить программу, Запрашивающую у пользователя значение переменной "t"- времени в течение суток - и выдачи текста: « Вы уже проснулись?», если t =18;

«Как работается?», в остальных случаях

Показать ответ
Ответ:
Марси667
Марси667
03.12.2022 14:00
Это может быть любое число, которое на 11 больше, чем число кратное 15. Например, 105 делится на 15 нацело. Значит число 116 вполне подходит под задуманное Ипполитом.

Все возможные варианты:
101 116 131 146 161 176 191 206 221 236 251 266 281 296 311 326 341 356 371 386 401 416 431 446 461 476 491 506 521 536 551 566 581 596 611 626 641 656 671 686 701 716 731 746 761 776 791 806 821 836 851 866 881 896 911 926 941 956 971 986 

Пример программы (и, соответственно, алгоритма), при которого можно получить такой список - во вложении.
Ипполит задумал трехзначное число которое при делении на 15 дает в остатке 11
0,0(0 оценок)
Ответ:
Кимиджими3
Кимиджими3
09.05.2020 07:48
Var
   A:array[1..10000,1..10000] of integer;
   i,j,N:integer;
   S,P:real;
Begin
Randomize;
P:=1;
Write('N = ');ReadLn(N);
For i:= 1 to N do
    Begin
    For j:= 1 to N do
        Begin
        A[i,j]:=random(21)-10;
        Write(A[i,j]:3,' ')
        End;
    WriteLn
    End;
j:=1;
Repeat
S:=0;
For i:= 1 to N do
    S:=S+A[i,j];
P:=P*S;
j:=j+2;
Until j>N;
WriteLn('P = ',P);
End.

N = 7
 -8   4   4   6  -6  -3   1
 -6  -6   8   7   8   8   2
  5  -2   5   7  -4   9  -1
  0  10   2  -5   9   9   3
  2   8   2 -10  -6  -4  -6
 -7   3  -4   9   2   4  -3
  6   4  -3   0   1   4  -5
P = 4032
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота