В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
shootdm100
shootdm100
12.12.2022 20:29 •  Информатика

По паскалю. 1. написать программу, которая вводит последовательность вещественных чисел, состоящую из n элементов, и определяет, является ли эта последовательность возрастающей. 2. дан целочисленный массив размерности n. необходимо "сжать" массив, выбросив из него каждый второй элемент. дополнительный массив использовать нельзя.

Показать ответ
Ответ:
Котя534
Котя534
27.05.2020 17:51

var a:array[1..1000]of longint;
n,i,kol:longint;
begin
read(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n-1 do
if a[i]<a[i+1] then kol:=kol+1;
if kol=n then write('vorast') else writeln('net');
end.

 

 

var a:array[1..1000]of longint;
n,i:longint;
begin
read(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if i mod 2 <>0 then write(a[i],' ');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота