В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Kseniya000001
Kseniya000001
20.10.2020 00:45 •  Информатика

По информатике составить программу в паскале.создать одномерный массив а из 10 целых чисел (с рандома в диапазоне (-50; 100). посчитать количество отрицательных и неотрицательных элементов массива.

Показать ответ
Ответ:
R1FL
R1FL
08.10.2020 02:26
// PascalABC.NET 3.3
begin
  var a:=ArrRandom(10,-50,100); a.Println;
  var k:=a.Where(x->x<0).Count;
  writeln('Количество отрицательных = ',k,
          ', количество неотрицательных = ',10-k);
end.

Пример:
66 47 65 70 -3 81 45 70 -33 -31
Количество отрицательных = 3, количество неотрицательных = 7
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота