Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
romakim02kum
05.10.2022 11:44 •
Информатика
ПО ИНФОРМАТИКЕ
Построить все 4 фигуры в одной программе, используя команду WHILE
Все размеры выбираются на ваше усмотрение.
Показать ответ
Ответ:
morkovcha
17.07.2020 02:41
#include <stdio.h>
#include <iostream>
#include <malloc.h>
const int N = 10;
int main()
{
setlocale(LC_ALL, "RUS");
int i, j=0, n=0;
int array[N];
int *a;
puts("Исходный массив:");
for (i=0; i<N; i++) {
printf("Введите %d элемент:", i);
scanf("%d", &array[i]);
}
system("cls");
puts("Исходный массив:");
for (i=0; i<N; i++) {
printf("%d ", array[i]);
}
printf("\n");
for (i=0; i<N; i++)
if (array[i] == 0)
n++;
printf("Новый массив:\n");
a = (int *)malloc(n*sizeof(int));
for (i=0; i<N; i++)
if (array[i] == 0) {
a[j] = i;
printf("%d ", a[j]);
j++;
}
free(a);
printf("\n");
system("pause");
return 0;
}
Тестовое решение:
Исходный массив:
5 0 3 6 0 0 2 1 0 5
Новый массив:
1 4 5 8
Для продолжения нажмите любую клавишу . . .
0,0
(0 оценок)
Ответ:
swvw
27.03.2023 21:32
В PascalABC.Net
var
x:real;
begin
Writeln(' x y');
x:=-1;
while x<=1 do
begin Writeln(x:4:1,10-cos(Pi*x):10:5); x:=x+0.1 end
end.
Результат выполнения программы:
x y
-1.0 11.00000
-0.9 10.95106
-0.8 10.80902
-0.7 10.58779
-0.6 10.30902
-0.5 10.00000
-0.4 9.69098
-0.3 9.41221
-0.2 9.19098
-0.1 9.04894
0.0 9.00000
0.1 9.04894
0.2 9.19098
0.3 9.41221
0.4 9.69098
0.5 10.00000
0.6 10.30902
0.7 10.58779
0.8 10.80902
0.9 10.95106
1.0 11.00000
Замечание: В PascalABC константа Pi предопределена. В других версиях, если транслятор напишет сообщение о том, что переменная Pi не описана, в начале программы добавьте const Pi=3.14159265;
0,0
(0 оценок)
Популярные вопросы: Информатика
RaiderUp
05.08.2022 12:13
Тест по информатике ...
olgagolikova2
15.07.2022 05:49
Тест по информатике ...
Zaayeva
29.03.2021 03:07
На рассуждение. на столе поставлены в ряд бутылка минеральной воды, кружка, чашка, стакан и кувшин, причём точно в таком порядке, в каком они перечислены. в них находятся...
cthut2016
30.05.2021 07:37
По каналу навстречу друг другу движутся два корабля.канал узкий, и кораблям в нем не разойтись. в канале есть бухта, в которой помещается лишь один корабль. описать команды...
ivanpanyushkin1
30.05.2021 07:37
Скорость передачи данных через adsl-соединение равно 9216 байт/с. передача файла через это соединение заняла 1 минуту. запишите размер файла в килобайтах....
famm2
30.05.2021 07:37
1)какие объекты могут содержаться на слайдах презинтации? 2)какие свойства имеют слайды?...
Anyta31107
30.05.2021 07:37
Написать программу в pascal. дан файл f, компонентами которого являются действительные числа. вывести на экран разности между соседними элементами.(первый-второй, третий-четвертый,...
ironthewolf72
07.04.2023 10:32
Унас есть фотография размером 10 на 15 .каждый квадратный сантиметр содержит 600 точек, каждая точка описывается 4 битами . каков общий информационный объем фотографии...
Danila5535
11.11.2021 19:29
Даны два целых числа: d (день) и m (месяц), определяющие правильную дату. вывести знак зодиака, соответствующий этой дате: «водолей» (20.1–18.2), «рыбы» (19.2–20.3), «овен»...
гэлочка
11.11.2021 19:29
Можете написать на qbasic и составить блок-схему к нему? ввести массив из mxn элементов. сформировать три новых массива, повернув исходный на 90 градусов против часовой...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <iostream>
#include <malloc.h>
const int N = 10;
int main()
{
setlocale(LC_ALL, "RUS");
int i, j=0, n=0;
int array[N];
int *a;
puts("Исходный массив:");
for (i=0; i<N; i++) {
printf("Введите %d элемент:", i);
scanf("%d", &array[i]);
}
system("cls");
puts("Исходный массив:");
for (i=0; i<N; i++) {
printf("%d ", array[i]);
}
printf("\n");
for (i=0; i<N; i++)
if (array[i] == 0)
n++;
printf("Новый массив:\n");
a = (int *)malloc(n*sizeof(int));
for (i=0; i<N; i++)
if (array[i] == 0) {
a[j] = i;
printf("%d ", a[j]);
j++;
}
free(a);
printf("\n");
system("pause");
return 0;
}
Тестовое решение:
Исходный массив:
5 0 3 6 0 0 2 1 0 5
Новый массив:
1 4 5 8
Для продолжения нажмите любую клавишу . . .
var
x:real;
begin
Writeln(' x y');
x:=-1;
while x<=1 do
begin Writeln(x:4:1,10-cos(Pi*x):10:5); x:=x+0.1 end
end.
Результат выполнения программы:
x y
-1.0 11.00000
-0.9 10.95106
-0.8 10.80902
-0.7 10.58779
-0.6 10.30902
-0.5 10.00000
-0.4 9.69098
-0.3 9.41221
-0.2 9.19098
-0.1 9.04894
0.0 9.00000
0.1 9.04894
0.2 9.19098
0.3 9.41221
0.4 9.69098
0.5 10.00000
0.6 10.30902
0.7 10.58779
0.8 10.80902
0.9 10.95106
1.0 11.00000
Замечание: В PascalABC константа Pi предопределена. В других версиях, если транслятор напишет сообщение о том, что переменная Pi не описана, в начале программы добавьте const Pi=3.14159265;