Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
gavul79
14.07.2022 04:39 •
Информатика
По информатике написать программу в которой будет вычитаться из числа 1000 числа,введённые пользователем с клавиатуры до тех пор, пока разность не станет меньше 0. примечание применить цикл repeat,until буду
Показать ответ
Ответ:
KapitanNEMO
05.10.2020 07:25
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
begin
var t:=1000;
var k:integer;
repeat
k:=ReadInteger('->');
t-=k
until t<0;
Writeln('Всё...')
end.
Пример
-> 453
-> 216
-> 39
-> 64
-> 312
Всё...
Решение для "древних паскалей"
var
k,t:integer;
begin
t:=1000;
repeat
Write('->'); Read(k);
t:=t-k
until t<0;
Writeln('Всё...')
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
maslyuk05
11.02.2022 00:33
Задано число і вивести повідомленнямвоно додатнє відємне або =0...
pastor741
19.07.2021 18:15
Дана строка из n символов латинского алфавита нижнего регистра. Далее дано q строк длины n, для каждой i−й строки необходимо ответить на вопрос - является ли i−я строка...
ilyhan787228
29.10.2022 12:43
Менеджер находится в командировке. Ему необходимо привести очень важную для фирмы информацию. В его распоряжении находится только карта памяти, на которую можно поместить...
Gaky
06.07.2022 10:44
Склавиатуры последовательно вводятся однозначные числа до тех пор пока не будет введено двухзначное число.найди сумму квадратов однозначных чисел (написать программу...
aizy2
21.07.2022 08:01
Выведи на экран большее из двух данных чисел. Запиши программу на языке Паскаль, выведи ответ на экран, если 1,89462 и 2,7871....
gela06
27.11.2022 15:05
Составьте различные модели: Квадрата Прямой линии Человека...
BegimaiAnarkulova
01.12.2020 02:42
Базовая система ввода-вывода ( - базовая система ввода-вывода) называется так потому, что включает в себя обширный набор , благодаря которым операционная система и...
vyacheslavkotov
11.01.2021 05:26
Нельзя преобразовать real к integer проверил раз 10 , не могу найти ! program lol; const n=20; var a: array [1..n] of real; s: real; i: integer; begin s: =0; for i:...
vgorelova62
24.04.2021 07:42
в ячейку f13 ввели формулу =a13/sb$4. затем эту формулу протянули маркером автозаполнения до ячейки f16. ячейке f16 содержится формула =a16/sbs4 =a16/sbs7 =a13/sb54...
grishinaanfisa
13.04.2021 05:22
Расписание автобусов. В следующих таблицах показано, когда автобусы будут останавливаться на каждой остановке. Вопрос: Если бобер Джеймс находится на остановке А в...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
var t:=1000;
var k:integer;
repeat
k:=ReadInteger('->');
t-=k
until t<0;
Writeln('Всё...')
end.
Пример
-> 453
-> 216
-> 39
-> 64
-> 312
Всё...
Решение для "древних паскалей"
var
k,t:integer;
begin
t:=1000;
repeat
Write('->'); Read(k);
t:=t-k
until t<0;
Writeln('Всё...')
end.