В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
саша4275
саша4275
16.12.2022 22:54 •  Информатика

По информатике: написать программу на языке паскаль: (1)заданы стороны прямоугольника. определить периметр и площадь прямоугольника. (2) написать программу которая находит среднее арифметическое двух чисел. если ещё не трудно объяснить а то до меня не доходит как это заранее !

Показать ответ
Ответ:
TheVadCom
TheVadCom
29.05.2020 01:10

1)

program qq;

var a,b,s,p : integer;

begin

writeln('Введите стороны прямоугольника');

read(a,b);

s:=a*b;

p:=2*(a+b);

writeln('Площадь прямоугольника равна ',s);

writeln('Периметр прямоугольника равен ',p);

end.

2)

Var a,b : Real;

Function SrAr(aa,bb :Real) : Real;

Begin

 SrAr:=(aa+bb)/2;

end;

Begin

 Readln(a,b);

 Writeln(SrAr(a,b));

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота