В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
настячччч
настячччч
11.02.2023 08:57 •  Информатика

По c++!

изменение исходного массива

дан двумерный массив из четного числа строк размером n×m. требуется составить программу, которая меняет местами первую строку со второй, третью — с четвертой и т. д.

первая строка содержит два натуральных числа n, m (n,m≤100).

следующие n строк содержат по m чисел, не превосходящих 109 по модулю — элементы массива.

требуется вывести n строк по m чисел в каждой — измененный массив.

входные данные

4 3

1 2 3

4 5 6

7 8 9

9 8 7

выходные данные

4 5 6

1 2 3

9 8 7

7 8 9

Показать ответ
Ответ:
086Alex
086Alex
11.10.2020 03:00

#include <iostream>

int main(){

  int n, m;

  std :: cin >> n >> m;

  int array[109][109];

  for (int i = 0; i<n; ++i){

      for (int j = 0; j<m; ++j)

      {

            if (i==0 || i%2==0) std :: cin >> array[i+1][j];

            else std :: cin >> array[i-1][j];

      }

  }

   for (int i=0; i<n; ++i){

       for (int j= 0; j<m; ++j)

       {

            std :: cout << array[i][j]<< ' ';

       }

       std :: cout << std :: endl;

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота