В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kotlaralina
kotlaralina
25.09.2022 18:11 •  Информатика

Плата arduinouno написать программу, которая будет считывать значение с ультразвукового дальномера и выводить их на lcd дисплей, далее подключить сервопривод и сделать так, чтобы он поворачивался на тот градус чему равно расстояние. к примеру расстояние равно 55 см значит сервопривод повернуть на 55 градусов. дойдя до 180 градусов и при увеличении расстояния сервопривод должен начать вращение в обратном направлении. к примеру 180 см это 180 градусов, а 190 см это уже 170 градусов и так далее.

Показать ответ
Ответ:
slavik116
slavik116
12.10.2021 16:48

Объясняю: нужно найти сумму каждого участника, после чего найти максимальное значение и вывести его на экран. 

Сначала мы вводим эти самые , потом складываем. Далее Sort3(Iv,Pet,Sid) - это функция. Если вы не знакомы с функциями, то просто перерисуйте вместо этого укрупненного блока все, что на следующей странице, вместо переменных а, в и с подставляя те переменные, которые вы используете для хранения суммы участников. 

Что делает функция Sort3: он сортирует по убыванию значения, хранящиеся в переменных а,в и с. После чего для того, чтобы получить максимальное значение, нам достаточно вывести первый элемент - а. Функция Swap  выполняет обмен значений переменных. Sort2 - сортирует два элемента. Она вс для Sort3. 

В основной программе вместо переменных а,в и с использовались переменные Iv, Pet и Sid. При неиспользовании функций подставляйте их. 

Можно использовать простые развилки и не заморачиваться с Sort3, но выходит неэффективно, некрасиво.При увеличении числа участников количество развилок вырастет в несколько раз - оно вам надо? Проще отсортировать. 

 

0,0(0 оценок)
Ответ:
SerStroka
SerStroka
14.07.2020 09:46

1) uses crt;
var a,s:real;
i,n:integer;
begin
write('Введите число А: ');
readln(a);
write('Введите число N: ');
readln(n);
s:=1;
for i:=1 to n do begin
s:=s*a;
end;
writeln('Число ',a,' в степени ',n,' равно ',s);
end.

2)uses crt;
var a,s:real;
i,n:integer;
begin
write('Введите число А: ');
readln(a);
write('Введите число N: ');
readln(n);
s:=1;
for i:=1 to n do begin
s:=s*a;
writeln(a,' в степени ',i,' равно ',s);
end;
end.

3)uses crt;
var a,s,p:real;
i,n:integer;
begin
write('Введите число А: ');
readln(a);
write('Введите число N: ');
readln(n);
s:=1;
p:=1;
write('1 + ');
for i:=1 to n do begin
s:=s*a;
p:=p+s;
if i<n then write(s,' + ');
if i=n then write(s,' = ');
end;
writeln(p);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота