В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Питон Посчитать кол-во чётных и нечётных цифр в числе

Входные данные

2345

Выходные данные

2 2​

Показать ответ
Ответ:
svetlanasalamon
svetlanasalamon
04.11.2022 19:38

N = int(input())

X = [''] * N

for a in range(N):

   X[a] = int(input())

a = 0

c, b, e, f = 0, 0, 0, N + 1

g, h = 0, 0

while a < N - 2:

   a += 1

   e += 1

   b, c = X[a], b

   if c < b:

       while a < N - 1:

           a += 1

           e += 1

           d = X[a]

           if d < b:

               if e < f:

                   g, h = a - e + 1, a + 1

                   f = e

               break

           elif d == b:

               continue

           else:

               break

   e = 0

if g == 0 and h == 0:

   print(0)

else: print(g, h)

Объяснение:

на

0,0(0 оценок)
Ответ:
динозавр777
динозавр777
20.05.2020 18:28

N = int(input())

X = [''] * N

for a in range(N):

   X[a] = int(input())

a = 0

c, b, e, f = 0, 0, 0, N + 1

g, h = 0, 0

while a < N - 2:

   a += 1

   e += 1

   b, c = X[a], b

   if c < b:

       while a < N - 1:

           a += 1

           e += 1

           d = X[a]

           if d < b:

               if e < f:

                   g, h = a - e + 1, a + 1

                   f = e

               break

           elif d == b:

               continue

           else:

               break

   e = 0

if g == 0 and h == 0:

   print(0)

else: print(g, h)

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота