В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
monyamirzoeva
monyamirzoeva
13.03.2021 07:15 •  Информатика

Питон напишите программу, выводящую все биты 8-битного числа входные данные дано число a (0≤a≤255). выходные данные выведите число a в битовой форме: 8 бит, старшие биты слева, младшие – справа. примеры входные данные 5 выходные данные 00000101

Показать ответ
Ответ:
milka230614
milka230614
30.07.2020 21:21
Вот один из вариантов:

s=str(bin(int(input("Введите число от 0 до 255: "[2:].rjust(8,"0")
print(s)

Объяснения:
1) input("Введите число от 0 до 255: ") организует ввод символьной строки
2) int() преобазует введенную строку к целому числу
3) bin() преобразует целое число к строке с его двоичным извображением и слева добавляет признак "ob"
4) [2:] - срез строки обеспечивает отсечение левых двух символов (т.е. "0b")
5) .rjust - метод, добавляющий в строку слева символы-заполнители (в нашем случае "0") до указанной длины (8).
6) и в переменную s заносится полученный результат

Тестовые решения:

Python 3.4.2 (v3.4.2:ab2c023a9432, Oct  6 2014, 22:15:05) [MSC v.1600 32 bit (Intel)] on win32
Type "copyright", "credits" or "license()" for more information.
>>> RESTART
>>>
Введите число от 0 до 255: 0
00000000

Введите число от 0 до 255: 255
11111111

Введите число от 0 до 255: 74
01001010
0,0(0 оценок)
Ответ:
Ксения1234561040
Ксения1234561040
30.07.2020 21:21
A = int(input())
s = ""
for i in range(8):
    s = s[:i] + str(a % 2) + s[i:]
    a = a // 2
for i in range(len(s)):
    print(s[len(s)-i-1],end='')
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота