В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Vens12
Vens12
13.04.2020 16:52 •  Информатика

ПИТОН! Написать программу, для решения уравнение: Ax=B. Переменные А, B вводятся через клавиатуру через консоль. x-неизвестное. Про область допустимых значений не забываем. Помните, что на ноль делить нельзя. Материал может пригодится

Показать ответ
Ответ:
moiznaniya1112
moiznaniya1112
14.03.2020 17:50

Деректер қорын басқару жүйелері

Өз ойыңызбен бөлісіңіз

Біз үлкен көлемдегі деректерді қалай сақтап, өңдейміз?

Деректер қоры дегеніміз не?

Деректер қорын жасау не үшін қажет?

Деректер қорын жинақтауға арналған қандай программаларды білесіңдер?

Кез келген кәсіпорын немесе ұжым Деректер қорын басқару жүйелерін (ДҚБЖ) жасайды. Олардың көмегімен Деректер қорын жасау­ға, ақпараттармен толықтыруға және жұмыс істеуге болатын программалар жинауға болады. Деректер қорын басқару жүйелерінің бірнеше ондаған түрлері бар, олардың көпшілігі – шындығына келгенде басқару жүйелері емес, арнайы дайындалған программалау тілдері. Осы тілді меңгерген әрбір адам қолданушыға ыңғайлы құрылымдағы, кез келген деректер қорын жасап алуына және оларға қажетті басқару элементтерін енгізуіне болады.

ДҚБЖ (Деректер Қорын Басқару Жүйесі) – деректер қорынан деректерді құру, сақтау және алуды автоматтандыруға арналған программалар жиынтығы.

ДҚБЖ үш негізгі функциясы

1) Деректрді анықтау (деректер қорының сипаттамасы);

​2) Деректерді өңдеу;

​3) Деректерді басқару.

Осы функциялардың барлығын Microsoft Access-те толықтай қолдануға болады.

Тағы да осы тақырып бойынша Басқа іс-әрекеттер

Деректер қорына қойылатын талаптар  

✔ мәліметтер қорының мазмұнын көшіруді болдырмау немесе азайту;

​✔пайдаланушы топтардың құқықтары мен талаптарына сәйкес, деректер қорының жекелеген ақпараттық элементтерге енуін жеделдетуді қамтамасыз ету;

​✔ үнемі өсіп отыратын талаптарды қанағаттандыру үшін деректер қорының кеңейтілу мүмкіншіліктерін қамтамасыз ету;

​✔ тек қана дұрыс, алдын ала тексерілген ақпараттарды пайдалануды қамтамасыз етуге мүмкіндік беретін деректер қорының тұтас­тығын сақтау;

​✔деректер қорының, тұтынушылардың жекелеген санаттарының жұмыс істеуіне қажетті белгілі бір ақпараттық элементтерге енуіне ғана рұқсат беру;

​✔ қорға енуді, деректер қорына ақпараттар қосу мен түзетуді тек қана авторлық құқығы бар тұтынушылардың орындауы;

​✔ деректер қорын пайдаланушылардың талабына сәйкес, деректердің элементтерін, түзету, бейнелеу және есептеу құрылғыларын құрудың қарапайымдылығын қамтамасыз ету.

Есіңізде сақтаңыз

Деректерді сақтау – компьютердің маңызды функцияларының бірі. Оның ең көп тараған құралы – Деректер қоры (ДҚ). ДҚ – берілген құрылымдағы ақпараттардан тұратын арнайы форматтағы файл. Берілгендер кесте түрінде дайындалады.

Деректер қоры (ДҚ) – анықталған облысқа жататын деректерді басқару, сақтау және сипаттаудың жалпы ұстанымдарын анықталған ережелер бойынша қарастыратын ұйымдастырылған деректер жиынтығы.

Тағы да осы тақырып бойынша Басқа іс-әрекеттер

Деректердің арасындағы байланыстарды ұйымдастырудың түрлері

Деректердің арасындағы байланыстарды ұйымдастырудың келесі түрлері бар:

1) Иерархиялық;                                                          ​2) Желілік;                                                     ​3) Реляциялық.

Көптеген ДҚ кестелік құрылымда болады. Кестелік құрылымда берілгендердің адрестері жол мен бағананың қиылысуымен анықталады. Кестелерді жобалау кезінде олардың құрылымдарын алдымен қағазда жасаған ыңғайлы. Кестедегі әрбір өріс оның тақырыбына сәйкес болатын жеке мәліметтен тұрады. Әртүрлі кестедегі берілгендерді байланыстыру үшін, әрбір кестедегі жазбаның өзіндік жеке мәнін бере алатын өріс не өрістер жиынтығы болуы тиіс. Мұндай өріс не өрістер жиынтығын негізгі кілт деп атайды.

Объяснение:

0,0(0 оценок)
Ответ:
dpoarkov56
dpoarkov56
20.03.2022 02:46

program z1;

var a:array [1..20] of integer;

i,s,k:integer;

begin

randomize;

s:=0;

k:=0;

write('Массив: ');

for i:=1 to 20 do

begin

a[i]:=random(90)+10;

if a[i] mod 2 <> 0 then

begin

s:=s+a[i];

k:=k+1

end;

write(a[i],'  ')

end;

writeln;

writeln('Среднее арифметическое нечётных элементов: ',s/k:0:1)

end.

Объяснение:

Задаём значение элемента с random

Проверяем значение элемента на нечётность, если условие истинно, то считаем сумму и количество элементов

Выводим  значение элемента на экран

Выводим среднее арифметическое (результат деления суммы на количество) нечётных элементов

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота