В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Scruff17
Scruff17
16.07.2020 12:36 •  Информатика

Питон, либо паскаль. Написать программу, которая определяет, попадает ли точка с
заданными координатами X, Y в область, закрашенную на рисунке серым
цветом. Результат работы программы вывести в виде текстового сообщения.
Параметр R вводится с клавиатуры.


Питон, либо паскаль. Написать программу, которая определяет, попадает ли точка с заданными координа

Показать ответ
Ответ:
abarzenkov
abarzenkov
23.02.2021 15:36
1. Алфавит - это форма письменности, основанная на стандартном наборе знаков.
2. Мощность алфавита - это кол-во символов в нём
3. Ic=i*k , Ic – количество информации в сообщении, i – количество информации которое несет один знак, k – количество знаков в сообщении
4. Т.к. каждый символ может иметь 64 значения, то есть 2^{6} , то на каждый символ выделяется 6 бит(от 0 до 63, всего 64 варианта).Всего символов - 100. Значит всего нужно 6*100=600бит=75байт.
5. Это единицы размера полученной и переданной информации и размера файла.
Килобайт = 1024 байт
Мегабайт = 1024 килобайт
Гигабайт = 1024 мегабайт
6. Дано: текст 3.5 килобайта

Найти: количество символов в тексте

Решение: Итак, текста у нас 3.5 килобайта

Переведём в байты:

3.5 кбайта * 1024 байт\килобайте = 3584 байт.

Так как кодировка не указана выбираем саму распространенную при обучении однобайтовую, тогда символ занимает ровно один байт и значит у нас

3584 символа. Если же используется двухбайтная кодировка, то 3584/2 = 1792 символа

ответ: 3584 для одного байта на символ или 1792 сиволов для двух байтной кодировки.
7. В первом тексте информационный объем одного символа составляет

N=2^i

32=2^5

i=5 бит

Во втором текте

64=2^6

i=6

Значит, в 1,2 раза (6:5=1,2)
0,0(0 оценок)
Ответ:
artesmenil
artesmenil
23.05.2020 21:28
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

type
  tL=List<integer>;

function Avg(L:tL):=L.Average;

function Cont(L:tL; e:integer):=L.Contains(e);

function Occurs(L:tL; e:integer):=L.Where(t->t=e).Count;

begin
  var MyList:=Lst(3,8,12,5,16,9,5,-2,7,0,5,-1);
  MyList.Println;
  Writeln('Среднее равно ',Avg(MyList):0:3);
  var k:=ReadInteger('Введите элемент для поиска:');
  Writeln('Есть ли такой элемент в списке? ',Cont(MyList,k));
  Writeln('Количество таких элементов равно ',Occurs(MyList,k))
end.

Пример
3 8 12 5 16 9 5 -2 7 0 5 -1
Среднее равно 5.583
Введите элемент для поиска: 5
Есть ли такой элемент в списке? True
Количество таких элементов равно 3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота