В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Петя и вася придумали язык программирования "мозг". в нём используются 8 ячеек памяти, и есть следующие операторы: оператор действие > > перейти к следующей ячейке < < перейти к предыдущей ячейке ++ увеличить значение в текущей ячейке на 1 -− уменьшить значение в текущей ячейке на 1 [[ если значение текущей ячейки ноль, перейти вперёд по тексту программы на ячейку, следующую за соответствующей ] (с учётом вложенности) ]] если значение текущей ячейки не ноль, перейти назад по тексту программы на символ [ (с учётом вложенности) .. напечатать значение из текущей ячейки исполнение программы начинается с третей ячейки. на момент запуска ячейки имеют следующие значения: номер ячейки 1 2 3 4 5 6 7 8 значение 10 330 50 19 17 0 184 0 запишите число, которое выведет программа: [-> [-> +> +< < ]> > [-< +< +> > ]< < < ]> > .[−> [−> +> +< < ]> > [−< +< +> > ]< < < ]> > . примечание: под вложенностью операторов [ и ] подразумевается однозначное соответствие оператора [ к оператору ] и наоборот по аналогии с открывающими и закрывающими скобками из . пример: для программы [-> +[-]< ][−> +[−]< ] первая открывающая квадратная скобка соответствует второй закрывающей квадратной скобке, а вторая открывающая квадратная скобка соответствует первой закрывающей квадратной скобке.

Показать ответ
Ответ:
bdhdt
bdhdt
07.10.2020 11:28
В принципе, можно расписать, что делает эта программа (см. вложение). Так как изначально a[6] = 0, то a[3] = 50 раз к a[5] прибавится 2 * a[4] = 38, получится 38 * 50 + a[5] = 1917, затем значение a[5] будет выведено на экран.

Но проще не мучиться и просто написать программу, выполняющую этот код.

python 3.
array = [10, 330, 50, 19, 17, 0, 184, 0]
array_position = 2
program = "[->[->+>+<<]>>[-<+<+>>]<<<]>>."

stack = []
transitions = [None] * len(program)
for k, op in enumerate(program):
    if op == '[':
        stack.append(k)
    elif op == ']':
        v = stack.pop()
        transitions[k] = v + 1
        transitions[v] = k + 1
 
k = 0
while k < len(program):
    op = program[k]
    if op == '.':
        print(array[array_position])
    elif op == '>':
        array_position += 1
    elif op == '<':
        array_position -= 1
    elif op == '[' and array[array_position] == 0:
        k = transitions[k]
        continue
    elif op == ']' and array[array_position] != 0:
        k = transitions[k]
        continue
    elif op == '+':
        array[array_position] += 1
    elif op == '-':
        array[array_position] -= 1
    k += 1
Петя и вася придумали язык программирования мозг. в нём используются 8 ячеек памяти, и есть следую
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота