Переведите с Паскаля в Java
const
m = 20;{максимальное количество элементов}
var
a: array[1..m] of real;
i, n: integer;
begin
Write('Введите количество элементов (от 1 до 20): ');
Readln(n);
Writeln('Вводите через пробел элементы массива');
for i := 1 to n do
begin
Read(a[i]);
a[i] := sqr(a[i])
end;
Writeln('Результирующий массив:');
for i := 1 to n do Write(a[i]:0:4, ' ');
Writeln
end.
Зачем нужны программы распознавания текста.
С их выполняется редактирование информации, исправление ошибок, сохранение данных в нужном формате и т.
Как происходит распознавание текста?
Поэтапное сканирование и распознавание текста. ... Далее происходит проверка на предмет синтаксических и орфографических ошибок
Какие программы распознавание текста вы знаете?
Они с легкостью переведут pdf, jpg, png или «бумажный файл» в редактируемый формат для Word и прочих офисных приложений.
ABBYY FineReader.
OCR CuneiForm.
Readiris Pro.
Freemore OCR.
ABBYY Screenshot Reader.
Adobe Acrobat Pro.
Scanitto Pro.
RiDoc.
Какими пользовались?
ABBYY FineReader.
OCR CuneiForm.
Объяснение:Телефон
У бизнесмена есть телефон, который он использует для связи с партнерами по бизнесу. Сегодня у предпринимателя запланированы n разговоров, про каждый из которых известно число Pi — сколько рублей прибыли получит бизнесмен, если i-й разговор состоится (Pi может быть равно 0 — в этом случае никакой выгоды от i-го разговора нет).
Телефон у бизнесмена сделан по новейшим технологиям, но иногда барахлит. Сегодня, например, телефон внезапно разрядился, поэтому он позволит бизнесмену провести только первые A0 разговоров, а затем выключится до конца дня. Однако телефон можно зарядить, пропустив несколько первых запланированных разговоров. Более формально, если предприниматель будет заряжать телефон вместо первых j разговоров (то есть разговоров с номерами от 1 до j), то он потом сможет провести ровно Aj разговоров (с номерами от j + 1 до min(n, j + Aj)), после чего телефон опять же перестанет работать до конца дня.
Напишите программу, которая вычислит, сколько разговоров надо пропустить бизнесмену, чтобы заработать как можно больше. Если существует несколько ответов, то выведите тот, который требует большего времени зарядки, так как бизнесмену хочется отдохнуть подольше перед звонками.
напишите программу с++ или python
На вход программе дается целое число n — количество запланированных звонков (1 ≤ n ≤ 2·105). На следующей строке вводятся через пробел n целых чисел Pi, обозначающие прибыли от звонков (0 ≤ Pi ≤ 1 000). Затем вводятся n+1 целых чисел Aj, обозначающие, сколько звонков можно будет провести после подзарядки (0 ≤ Aj ≤ 106)