В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
arhipflina
arhipflina
26.02.2023 06:55 •  Информатика

Перестановка У вас есть массив чисел длиною "N". Нужно найти умноженную вариацию массива. Умноженный вариант массива это такой массив, где nums[i] это произведение всех чисел кроме nums[i]. Например, для массива [1,2,3,4] ответ будет равен [24,12,8,6].

Входные данные:

(1 ≤ n ≤ 10000), где каждый элемент в массиве в промежутке (-10000 ≤ a[i] ≤ 10000)

Выходные данные:

Нужно найти умноженную вариацию массива.

Показать ответ
Ответ:
MariNika2000
MariNika2000
03.01.2021 19:24

python

arr = [int(i) for i in input('Введите числа через пробел: ').split()]

new_arr = []

for forbidden_index in range(len(arr)):

 first = True

 for index in range(len(arr)):

   if index != forbidden_index:

     if first:

       new_arr.append(arr[index])

       first = False

     else:

       new_arr[forbidden_index] *= arr[index]

print(new_arr)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота