В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
daniil12341234
daniil12341234
14.05.2023 16:45 •  Информатика

Перестановка У вас есть массив чисел длиною "N". Нужно найти следующую перестановку массива. Ниже приведены несколько примеров для перестановка массива.

1,2,3 → 1,3,2

3,2,1 → 1,2,3

1,1,5 → 1,5,1

Входные данные:

(1 ≤ n ≤ 10000), где каждый элемент в массиве в промежутке (-10000 ≤ a[i] ≤ 10000)

Выходные данные:

Нужно найти следующую перестановку массива.

Показать ответ
Ответ:
secret213p089no
secret213p089no
18.03.2020 22:18

Какая бы не была прекрасная и чёткая система автоматизирования - она может ошибаться. Да, в нынешнем мире она делает это всё реже и реже, но, всё же, она ошибается. Человек должен её контролировать, обезопасить, в первую очередь, себя и себе подобных от её неправильных действий, которые могут навредить. В конце концов эту систему создал человек, а человек, как мы знаем, тоже ошибается и никогда не сотворит идеал (хотя, кто знает). Значит его детище - автоматизированная система управления в данном случае - тоже не может быть идеальной и может ошибаться. Поэтому, конечно, её нужно контролировать.

Таков мой ответ. Он очень субъективен, соглашаться с ним или нет - решать Вам :)

0,0(0 оценок)
Ответ:
kuvandykov05
kuvandykov05
31.10.2020 07:05

Код ниже (также можете свериться со скриншотами):

№1:

var x,y: real;

begin

   write('x = ');

   read(x);

   if (x < 5) then

   begin

       y:= sqrt(x+25);

   end;

   if (x = 5) then

   begin

       y:= 500;

   end;

   if (x > 5) then

   begin

       y:= (x/4);

   end;

   writeln('y = ',y:2:2);

end.

№2:

var x,y: real;

begin

   write('x = ');

   read(x);

   if (x < -1) then

   begin

       y:= x+2;

   end;

   if ((x >= -1) and (x < 5)) then

   begin

       y:= sqr(x+2);

   end;

   writeln('y = ',y:0:0);

end.


Написать ДВЕ программы на паскале. (Вычисления функции)
Написать ДВЕ программы на паскале. (Вычисления функции)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота