В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
AnyaFilenkova
AnyaFilenkova
12.01.2022 20:35 •  Информатика

Перечень практических заданий 1. Написать программу, заполняющую массив четными числами от 1 до 51 и вывести его на экран.

2. Написать программу, заполняющую массив нечетными числами от 1 до 61 и вывести его на экран.

3. Имеется массив из 10 элементов, которые являются случайными числами в интервале от 1 до 100. Написать программу нахождения суммы элементов массива, которые делятся на 5, но не делятся на 2.

4. Написать программу, заполняющую массив числами 1,14,19,116,…1100 и вывести его на экран.

5. Написать программу, осуществляющую ввод 10 элементов массива и выполняющую подсчет количества нулевых, отрицательных и положительных элементов.

6. Составьте программу, рассчитывающую функцию:

={2√3+322,<0.,≥0,

7. Составить программу, получающую при вводе два целых числа. Программа должна выводить слово yes, если остаток от деления первого числа на второе или второго на первое равен 1. Если остаток от деления первого числа на второе равен 2, то программа должна выводить слово yes+. Во всех остальных случаях программа должна выводить слово no.

8. Составить программу, рассчитывающую значение функции =3+− на участке определения [-1;1] с шагом Δx=0,2. Коэффициенты b, c вводятся с клавиатуры. Результатом работы программы является таблица со значениями аргумента и функции, выводящаяся с точностью до 2 знаков с точностью до 2 знаков после запятой. Использовать оператор цикла repeat.

9. Составить программу, рассчитывающую значение функции =32+2.5+4 на участке определения [-2;2] с шагом Δx=0,5. Результатом работы программы является таблица со значениями аргумента и функции, выводящаяся с точностью до 2 знаков с точностью до 1 знака после запятой. Использовать оператор цикла for.

10. Составить программу , рассчитывающую количество цифр в целом числе n. Целое число n вводится с клавиатуры. Использовать операции целочисленного деления div и получения остатка от целочисленного деления mod. Результатом работы программы является число цифр.

11. Написать программу вычисления суммы первых n элементов знакочередующегося степенного ряда:=1−1!+22!−33!+⋯+(−1)!

12. Написать программу, осуществляющую подсчет количества слов в тексте. Слова в тексте разделены одним пробелом.

13. Дано трехзначное целое число. Написать программу, определяющую наибольшую цифру числа.

Показать ответ
Ответ:
Sashafhvh
Sashafhvh
21.03.2021 20:38

#include <iostream>

#include <string>

using  namespace std;

int main()

{

string w;

int b;

string arr;

 

getline(cin,w);

cin>>b;

cin.ignore();

getline(cin,arr);

 

if(w == "szyfruj")

{

 for(int i=0; i<arr.size(); i++)

 {

  if(int(arr[i])>=97 &&  int(arr[i])<=122 || int(arr[i])>=65 && int(arr[i])<=90)

  {

   if(int(arr[i])>=97 &&  int(arr[i])<=122)

   {

    if(int(arr[i])+b>122) arr[i]-=26;

    arr[i]+=b;

   }

   else

   {

    if(int (arr[i])+b>90) arr[i]-=26;

    arr[i]+=b;

   }

  }

 }

}

if(w == "odszyfruj")

{

 for(int i=0; i<arr.size(); i++)

 {

  if(int(arr[i])>=97 &&  int(arr[i])<=122 || int(arr[i])>=65 && int(arr[i])<=90)

  {

   if(int(arr[i])>=97 &&  int(arr[i])<=122)

   {

    if(int(arr[i])-b<97) arr[i]+=26;

    arr[i]-=b;

   }

   else

   {

    if(int (arr[i])-b<65) arr[i]+=26;

    arr[i]-=b;

   }

  }

 }

}

cout<<arr;

return 0;

}

Объяснение:

код  на с++ для примера

пункт  со  сдвигом  букв сам  сделаешь  

P. S.  у меня на  5 они  сдвигаются,

0,0(0 оценок)
Ответ:
alenaafaunova
alenaafaunova
20.02.2023 06:37

/*

   Методов решения много, самый но длинный - это switch ... case..

   Можно было использовать map из STL

*/

#include <iostream>

#include <vector>

#include <sstream>

using namespace std;

int main()

{

   int number;

   cin>>number;

   switch (number){

   case 1:

       cout<<"Понедельник\n";

       break;

   case 2:

       cout<<"Вторник\n";

       break;

   case 3:

       cout<<"Среда\n";

       break;

   case 4:

       cout<<"Четверг\n";

       break;

   case 5:

       cout<<"Пятница\n";

       break;

   case 6:

       cout<<"Суббота\n";

       break;

   case 7:

       cout<<"Воскресенье\n";

       break;

   default:

       cout<<"Нет дня недели под этим номером";

   }

   return 0;

}

Краткий гайд:

number - переменная, отвечает за номер дня неделиswitch - case - оператор множественного выбора. Подробнее читаем на cppstudio.com, cppreference.com или других порталах
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота