В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Artem517Art
Artem517Art
04.06.2022 21:40 •  Информатика

ПАЙТОН Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округляя значения скорости до целых чисел. Необходимо определить среднюю зарегистрированную скорость всех автомобилей. Если скорость хотя бы одного автомобиля была не меньше 60 км/ч, выведите «YES», иначе выведите «NO». Программа получает на вход число проехавших автомобилей N (1 ≤ N ≤ 30), затем указываются их скорости. Значение скорости не может быть меньше 1 и больше 300. Программа должна сначала вывести среднюю скорость с точностью до одного знака после запятой, затем «YES» или «NO».

Показать ответ
Ответ:
алёчек
алёчек
10.04.2022 22:10

Программа:
Python:

N, summ, speed60 = int(input()), 0, False

for i in range(N):

   speed = int(input())

   if speed < 1 or speed > 300:

       print('Скорость не может быть меньше 1 и больше 300')

       continue

   else:

       summ += speed

   if speed >= 60 and not speed60: speed60 = True

print(round(summ/N, 1))

print('YES' if speed60 else 'NO')

Объяснение:

В начале вводится целое число N с клавиатуры, а также регистрируется переменняа summ, которой присваивается значение 0, переменная speed60 со значением False. Повторяем тело цикла N раз (с цикла for): вводится скорость с клавиатуры. По условию скорось не может быть меньше 1 и больше 300 - делаем проверку. Если скорость действительно за рамками допустимых значений, выводим предупреждение и не учитываем это значение в сумму скоростей. Если скорость от 1 до 300, то к значению переменной summ прибавляем значение скорости. Делаем проверку, скорость больше либо равно 60 км/ч или нет. Если да, и переменная speed60 на данный момент False, то присваиваем ей значение True. Цикл окончен. В конце выводим среднее значение, округлённое до десятых, в следующей строке выводим "YES" если была скорость, которая больше либо равно 60, иначе выводим "NO".

Результат:

10

102

106

102

062

58

276

27

3

5

6

74.7

YES

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота