В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Паскаль! Задано N точек на плоскости. Составить программу для подсчета количества точек, попавших в заданную область.


Паскаль! Задано N точек на плоскости. Составить программу для подсчета количества точек, попавших в

Показать ответ
Ответ:
наташа608
наташа608
06.07.2022 15:54

Несколько лет тому назад в одном из своих поместий жил старинный русский барин, Кирила Петрович Троекуров. Его богатство, знатный род и связи давали ему большой вес в губерниях, где находилось его имение. Соседи рады были угождать малейшим его прихотям; губернские чиновники трепетали при его имени; Кирила Петрович принимал знаки подобострастия как надлежащую дань; дом его его его егок его его всегда был полон гостями, готовыми тешить его барскую праздность, разделяя шумные, а иногда и буйные его увеселения. Никто не дерзал отказываться от его приглашения или в известные дни не являться с должным почтением в село Покровское. В домашнем быту Кирила Петрович выказывал все пороки человека необразованного. Избалованный всем, что только окружало его, он привык давать полную волю всем порывам пылкого своего нрава и всем затеям довольно ограниченного ума. Несмотря на необыкновенную силу физических , он раза два в неделю страдал от обжорства и каждый вечер бывал навеселе. В одном из флигелей его дома жили шестнадцать горничных, занимаясь рукоделиями, свойственными их полу. Окны во флигеле были загорожены деревянною решеткою; двери запирались замками, от коих ключи хранились у Кирила Петровича. Молодые затворницы в положенные часы сходили в сад и прогуливались под надзором двух старух. От того времени

0,0(0 оценок)
Ответ:
kotelnikovsanya
kotelnikovsanya
20.05.2021 18:28

ответ: я не понимаю, почему оно не тестится норимально, но вроде работает

n = int(input())

nc = [int(i) for i in input().split()]

snc = sum(nc)

a = []

q = int(input())

c = 0

for j in range(q):

   c += 1

   print(c)

   now = [int(i) for i in input().split(' ')]

   if len(now) == 2:

       ncnow = nc.copy()

       for i in range(len(nc)):

           nc[i] = ncnow[i-now[1]]

   else:

       item = nc[now[1]-1]

       nc[now[1]-1] = now[2]

       snc = snc - item + now[2]

   a.append(snc)

for i in a:

   print(i)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота