Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
nastgoliakova
05.01.2020 13:17 •
Информатика
Паскаль. за ! с клавиатуры вводится символьная строка. определите, сколько в ней цифр
Показать ответ
Ответ:
alidagalamova2003
03.10.2020 12:53
Var s:string; k,i:integer;
begin
write('Введите строку:');
readln(s);
k:=0;
for i:=1 to length(s) do
if (s[i]>='0')and(s[i]<='9') then k:=k+1;
writeln('k = ',k);
end.
Пример:
Введите строку:
13 апреля 2016 г .
k = 6
0,0
(0 оценок)
Ответ:
yaritos
03.10.2020 12:53
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
Write(ReadlnString('>').Where(c->c in ['0'..'9']).Count)
end.
Тестовое решение:
> Зде3сь спр14ята1ны 5 ци926ф5ры чи35сла8979 "пи"
15
0,0
(0 оценок)
Популярные вопросы: Информатика
fheeubeujdshebj
04.12.2022 09:29
Дано целое число n ( 0). вывести сумму 2 + 1/(2! ) + 1/(3! ) + + 1/(n! ) (выражение n! — n факториал — обозначает произведение всех целых чисел от 1 до n: n! = 1•2••n). полученное...
zoobbicom
04.05.2022 12:19
Дано целое число n и набор из n целых чисел. вывести номера тех чисел в наборе, которые меньше своего левого соседа, и количество k таких чисел. delphi 7...
Podoplel
27.07.2020 21:37
Решить программу на паскале. даны два символьных файла. переписать в третий файл символы из первого файла, которые не встречаются во в тором файле. содержимое файлов вывести на...
2Alinochka2
10.03.2023 17:05
Заполнить масив до ста в столбик программа для паскаль...
Хурем
15.11.2020 03:03
Го в world of tanks пешите ник в комменты патом поиграем (мой ник sokolov_56)...
АнастейшаГрей1
08.03.2023 18:11
13. Составить программу, проверяющую знание таблицы умножения. В программе выбираются случайным образом целые числа X (1 или равноX или равно9) и Y (1 или равноY или равно9) и...
Синуэлла
27.07.2022 22:22
Складіть карту знань із класифікацією загроз інформаційній безпеці користувача Інтернету....
antonmarusin
01.07.2022 22:22
14. Алгоритм - это…а) конечная последовательность действий, выполнение которых приводит к новой задаче.б)бесконечная последовательность команд, выполнение которых приводит к решению...
фывапрпиол
23.12.2020 04:36
Какие действия можно совершать с открытой таблицей? а) удалять записи б) изменять содержимое полей в) изменять структуру таблицы г) сортировать записи в алфавитном порядке ...
полли43
27.05.2022 13:54
Создать файл X компонентами, которого являются элемента массива M. Переписать из файла X в файл Y все компоненты, которые стоят на четных местах....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
write('Введите строку:');
readln(s);
k:=0;
for i:=1 to length(s) do
if (s[i]>='0')and(s[i]<='9') then k:=k+1;
writeln('k = ',k);
end.
Пример:
Введите строку:
13 апреля 2016 г .
k = 6
begin
Write(ReadlnString('>').Where(c->c in ['0'..'9']).Count)
end.
Тестовое решение:
> Зде3сь спр14ята1ны 5 ци926ф5ры чи35сла8979 "пи"
15