В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Alica56
Alica56
29.12.2022 16:20 •  Информатика

Паскаль.Вася пришел в магазин купить U карандашей и R ручек. Карандаши стоят L рублей, а ручки J рублей ему сосчитать, сколько рублей ему нужно на покупку. Напишите программу. Общую стоимость покупки обозначьте за S.

Показать ответ
Ответ:
anisimovamargar1
anisimovamargar1
13.04.2021 03:27
// PascalABC.NET 3.0, сборка 1088
const
  nDay:array[1..12] of integer=(31,28,31,30,31,30,31,31,30,31,30,31);
type
  Date=record
    Day,Month,Year:integer
  end;
 
function DOW(Dat:Date):integer;
// день недели по дате. 0-Вс. 1-Пн, 7-Сб
var
  a,y,m:integer;
begin
  With Dat do begin
    a:=(14 - month) div 12;
    y:=Year-a;
    m:=month+12*a-2;
    DOW:=(7000+(day+y+y div 4-y div 100+y div 400+(31*m) div 12)) mod 7
    end
end;

procedure DMY2Date(d,m,y:integer; var data:Date);
// Преобразует к дате заданные день, месяц и год
begin
  data.Day:=d; data.Month:=m; data.Year:=y
end;

procedure LastDays(month,year:integer; var Wd,Fr:Date);
// даты последней среды (Wd) и пятницы (Fr) для месяца в году }
var
  LastDay:Date;
  n:integer;
begin
  n:=nDay[month];
  if (month=2) and (year mod 4 = 0) then Inc(n);
  DMY2Date(n,month,year,LastDay);
  n:=DOW(LastDay); // номер последнего дня недели
  Wd.Month:=month; Wd.Year:=year;
  if n<3 then Wd.Day:=LastDay.Day-(n+4)
  else
    if n=3 then Wd.Day:=LastDay.Day
    else Wd.Day:=LastDay.Day+3-n;
  Fr.Month:=month; Fr.Year:=year;
  if n<5 then Fr.Day:=LastDay.Day-(n+2)
  else
    if n=3 then Fr.Day:=LastDay.Day
    else Fr.Day:=LastDay.Day-1
end;

var
  Wd,Fr:Date;
  ff,mf:Text;
  m:integer;
begin
  Assign(ff,'father.txt'); Rewrite(ff);
  Assign(mf,'mother.txt'); Rewrite(mf);
  // Сентябрь-декабрь 2015 года
  for m:=9 to 12 do begin
    LastDays(m,2015,Wd,Fr);
    if Odd(Wd.Day) then Writeln(mf,Wd.Day,'.',m,'.2015 - 1 класс')
    else Writeln(ff,Wd.Day,'.',m,'.2015 - 1 класс');
    if Odd(Fr.Day) then Writeln(mf,Fr.Day,'.',m,'.2015 - 5 класс')
    else Writeln(ff,Fr.Day,'.',m,'.2015 - 5 класс')
  end;
  // Январь - май 2016 года
  for m:=1 to 5 do begin
    LastDays(m,2016,Wd,Fr);
    if Odd(Wd.Day) then Writeln(mf,Wd.Day,'.',m,'.2016 - 1 класс')
    else Writeln(ff,Wd.Day,'.',m,'.2016 - 1 класс');
    if Odd(Fr.Day) then Writeln(mf,Fr.Day,'.',m,'.2016 - 5 класс')
    else Writeln(ff,Fr.Day,'.',m,'.2016 - 5 класс')
  end;
  Close(ff); Close(mf)
end.

Содержимое выходных файлов:
father.txt
30.9.2015 - 1 класс
28.10.2015 - 1 класс
30.10.2015 - 5 класс
30.12.2015 - 1 класс
24.2.2016 - 1 класс
26.2.2016 - 5 класс
30.3.2016 - 1 класс

mother.txt
25.9.2015 - 5 класс
25.11.2015 - 1 класс
27.11.2015 - 5 класс
25.12.2015 - 5 класс
27.1.2016 - 1 класс
29.1.2016 - 5 класс
25.3.2016 - 5 класс
27.4.2016 - 1 класс
29.4.2016 - 5 класс
25.5.2016 - 1 класс
27.5.2016 - 5 класс
0,0(0 оценок)
Ответ:
kotyara1234
kotyara1234
24.06.2020 01:07

Бобби Дик, Пуффендуй (около 20480 слов)

Что такое прорицание?

Задача этой науки заключается в предсказании или предугадывании грядущих

событий, которые уже существуют на планах космических и кармических

закономерностей.

Гадание (divination) - предсказание будущего, поиск пропавших объектов и

людей и установление виновности при информации, полученной из

каких-либо знамений, чар, снов, видений, а также с применением

специальных инструментов. С самого давнего времени во всех известных

цивилизациях люди обращались к сверхъестественным силам за и

советом в личных и государственных делах. В истории различают два вида

гадания: толкование природных явлений и интерпретация комбинаций

брошенных палочек, камней или костей. На протяжении долгой истории

гадание применялось для выявления преступников. Несмотря на особые

психологические прорицателей нередко наказанию подвергались

невинные люди.

Искусством гадания обладают ведьмы, волшебники, мудрецы, знахари, маги и

шаманы. В некоторых цивилизациях на протяжении всей их истории гаданием

занимался особый класс священнослужителей мужского или женского пола,

обладавших провидения и толкования знамений.

Наука пророков преподавалась всегда на высших ступенях всех древних

мистерий и была исключительным достоянием посвящённых жрецов. Это было

связано вовсе не с желанием обладать монополией в данной области, а с

высоким уровнем бытия, которого посвящённые добивались в этих тайных

школах, что и позволяло им вступать на планы, недоступные обычным

смертным.

Существовали, например, "Школы Пророков" в древней Палестине и Финикии,

которые имелись в городах Иерихон, Самария, Назарет, Вефин и др.

Руководили этими школами великие адепты-пророки. Их ученики, которых

называли "дети пророков", жили в условиях уединённой и суровой жизни с

постоянным обучением, молитвами, чтением Св. Писаний, медитацией.

Наконец, существовали храмы, принадлежавшие мистериям, в которых имелись

т. н. оракулы, отдельные жрецы или целые их коллегии, занимавшиеся

исключительно пророчествованием.

Так на острове Сен или Лиамбис близ Ушанта находилась коллегия

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота