В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
BaVeRSB
BaVeRSB
10.10.2020 04:24 •  Информатика

Паскаль в массиве

1. Составьте программу, задающую одномерный массив целых чисел из 6 элементов, вводимых с клавиатуры, и оформите вывод элементов на экран в строчку.

2. Составьте программу, задающую одномерный массив размерность 10, состоящий из случайных чисел из промежутка от 5 до 22. Оформите вывод элементов на экран в строчку.

Показать ответ
Ответ:
shapovalovalyubochka
shapovalovalyubochka
08.01.2023 11:12

#include <iostream>

#include <list>

int main()

{

   std::list<int> numbers;

   int x= 0;

   std::cin >> x;

   do {

       int k = x % 10;

       x /= 10;

       numbers.push_back(k);

   } while (x > 0);

   

   for (int n : numbers) {

       std::cout << n<<"\n";

   }

   return 0;

}

Класс list

Класс списка стандартной библиотеки C++ — это шаблон класса контейнеров последовательностей, который сохраняет свои элементы в линейном упорядочении и позволяет выполнять операции вставки и удаления в любом расположении в последовательности. Последовательность хранится в виде двунаправленного связанного списка элементов, каждый из которых содержит элемент какого-либо типа Type .


Сделать программу которая на фото только должен быть массив,ввод чисел с клавиатуры(с++,программа де
0,0(0 оценок)
Ответ:
меланамасимова
меланамасимова
08.01.2023 11:12

1.Упорядкований набір змінних одного типу називається табличною величиною, або одновимірним масивом. Кожна змінна (клітинка таблиці), що входить до табличної величини, називається її елементом.

2.var a: array[1..10] of real

3.Властивість — філософська категорія, яка виражає один з моментів виявлення сутності речі у відношеннях з іншими речами; те, що характеризує її подібність до інших предметів або відмінність від них. Властивість пов'язана з якістю (див. якість і кількість).

4.Багаторядкові текстові поля

Властивість MultiLine визнача іб відображення текстового поля. При встановленому значенні True текст елемента управління TextBox може розташовуватися на декількох рядках. При введенні інформації в поле для переходу на новий рядок необхідно натискати клавішу <Enter>.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота