В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ladhice
ladhice
04.03.2020 01:41 •  Информатика

Паскаль составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от -20 до 20. подсчитайте в этом массиве количество положительных и количество отрицательных значений.

Показать ответ
Ответ:
Гогенцоллерн
Гогенцоллерн
03.07.2020 10:20
Var a:array[1..100] of integer;
i,p,m:integer;
begin
p:=0;
m:=0;
for i:=1 to 100 do begin
a[i]:=random(-20,20);
if a[i]>0 then p+=1 else
m+=1;
end;
writeln('Положительных - ',p,' отрицательных - ',m);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота