В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
мозг3567
мозг3567
20.12.2020 22:38 •  Информатика

Паскаль. составьте программу подсчета числа различных составных элементов массива а(т,т).

Показать ответ
Ответ:
Chundokova
Chundokova
24.07.2020 15:01
Vara: array [1..10] of integer;
b:string;
c,i:integer;
begin
Randomize;
for  i:=1 to 10 do begin
a[i]:=Random(5);
write(a[i]);
end;
b:='';
c:=0;
for  i:=1 to 10 do
if (pos(inttostr(a[i]),b) =0) then begin b:=b+inttostr(a[i]); inc(c); end;
writeln(c);
end.
//ABC Pascal
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота