В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ulagrac8
ulagrac8
13.01.2023 17:06 •  Информатика

Паскаль составьте программу, которая заполняет массив 10-ю случайными целыми числами в диапазоне [1..20] и выводит на экран элементы массива в нечетными значениями.

Показать ответ
Ответ:
есенина1920
есенина1920
07.06.2020 01:46

var

  a: array [1..10] of integer; //Инициализируем массив из 10 целых чисел

  i: integer;

begin

  for i:= 1 to 10 do

  begin

    a[i]:= random(19) + 1; //Заполняем массив случайными числами от 1 до 20

    if a[i] mod 2 = 1 then write(a[i], '  '); {Если очередной элемент массива нечетный, то он выводится}

  end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота