В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Aydan666
Aydan666
05.11.2020 07:59 •  Информатика

ПАСКАЛЬ. Составить программу нахождения произведения цифр целого числа.

Показать ответ
Ответ:
sushenkop08wf4
sushenkop08wf4
28.11.2020 18:59

program comp;

var

 number, composition, last_number: integer;

begin

 composition := 1;

 read(number);

 while (number > 0) do

 begin

   last_number := number mod 10;

   composition := composition * last_number;

   number := number div 10;

 end;

 write(composition);

end.

Объяснение:

program comp;  // Название программы

var

 number, composition, last_number: integer;  // Создание целочисланных переменных:

number - число, которое вводится с клавиатуры;composition - переменная для хранения произведения цифр числа;last_number - переменная, которая будет хранить цифры числа.

begin  // Начало программы

 composition := 1;  // Переменной composition присваиваем значение 1

 read(number);  // Считываем число с клавиатуры

 while (number > 0) do  // Пока переменная number > 0 выполняем

 begin  // Начало цикла

   last_number := number mod 10;  // Берем последнюю цифру от числа (остаток от деления на 10)

   composition := composition * last_number;  // В переменную composition записываем произведение переменной composition и переменной last_number

   number := number div 10;  // Отделяем последнюю цифру от числа (целочисленное деление на 10)

 end;  // Конец цикла

 write(composition);  // Вывод значения переменной composition

end. // Конец программы

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота