Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Sasha190507
18.10.2022 03:42 •
Информатика
Паскаль составить программу для проверки, можно ли заданное натуральное число n представить в виде куба простого числа.
Показать ответ
Ответ:
kirillanisimovp08nm9
15.07.2020 17:28
Var n,k,m:integer;
begin
readln(n);
for k:=1 to n do
begin
m:=k*k*k;
if m=n then
begin
writeln(k,'*',k,'*',k,'=',n);
exit;
end;
end;
if (m<>n) then
writeln('Het');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
MAJlORIK
22.02.2023 17:31
Запиши верный ответ. Дано число 423000000. Данное число можно представить в виде 42,3⋅10...
sonyaway12
11.11.2020 05:48
Я в Instagram з іменем @drebotiy_ka. Установіть додаток, щоб стежити за моїми світлинами та відео. https://www.instagram.com/invites/contact/?i=7lg6jmce89cj&utm_content=5o30znn...
dashvali
09.05.2020 15:28
Мне нужна программа паскаль с циклом : ежедневно температура воздуха июля повышалась на пол градуса. какая температура была 20 июля, если 1 июля - 23 °?...
Elizaveta544435
27.09.2020 05:22
Решить на тему системы счисления 1, Перевести 17о в двоичную CC,2. Перевести 23ло в двоичну СС,3. Спожить двоичные числа из №1 и №24. Перевести двоичное число из №3 в...
anyalike
31.05.2022 11:08
Из З0 yчащихcя клacca нa ypoкe пpиcyтcтвyют 24 yчeникa. Нужно написать программу на пайтон, котороая выведет процент посещаемости....
Aleksey20052801
05.07.2022 03:20
Задача: Вивести числа 12 8 4, використовуючи цикл Repeat Задача: Знайдіть мінімальне число, яке менше за 100 та кратне 15. в Pascal ABC...
Dog7771
11.01.2023 03:09
ОЧЕНЬ Как провести анализ корреляционной зависимости на наличие линейной корреляции? Найти КОРРЕЛ что-ли?...
RomashechkaRomova
09.06.2023 09:31
Первым инструментом для счета можно считать 1. руку человека 2. палочки 3. арифмометр 4. камешки 2. По какому признаку отличаются поколения ЭВМ друг от друга? 1. По автору...
Angelikakat
26.12.2020 14:33
При упорядочивании информации в хронологической последовательности происходит … 1. обработка, связанная с изменением формы информации, но не изменяющая её содержания 2....
akarapiria4
12.05.2023 17:04
Расставьте знаки препинание и не правильные исправьте.перефразируйте если где то не совсем хорошо составлено предложеие. мы отправились в долгожданную поездку в пермь.лил...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
readln(n);
for k:=1 to n do
begin
m:=k*k*k;
if m=n then
begin
writeln(k,'*',k,'*',k,'=',n);
exit;
end;
end;
if (m<>n) then
writeln('Het');
end.