В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
skseeen15
skseeen15
14.03.2020 12:49 •  Информатика

Паскаль! ! провода дано n отрезков провода длиной l1, l2, ln сантиметров. требуется с разрезания получить из них k равных отрезков как можно большей длины, выражающейся целым числом сантиметров. если нельзя получить k отрезков длиной даже 1 см, вывести 0. ограничения: 1 < = n < = 10 000, 1 < = k < = 10 000, 100 < = li < = 10 000 000, все числа целые. входные данные в первой строке находятся числа n и к. в следующих n строках - l1, l2, ln, по одному числу в строке. выходные данные вывести одно число - полученную длину отрезков.

Показать ответ
Ответ:
rowa9712men
rowa9712men
08.09.2020 20:17
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var ЕстьКусков,НадоКусков:integer;
  Readln(ЕстьКусков,НадоКусков);
  var Длины:=ReadArrInteger(ЕстьКусков);
  var ОбщаяДлина:=Длины.Sum;
  if НадоКусков>ОбщаяДлина then Writeln(0)
  else begin
    var ДлинаКуска:=ОбщаяДлина div НадоКусков;
    repeat
      if Длины.Select(Кусок->Кусок div ДлинаКуска).Sum >=НадоКусков then break
      else ДлинаКуска-=1;
    until false;
    writeln(ДлинаКуска)
    end
end.

Пример
4 11
802 743 457 539
200
0,0(0 оценок)
Ответ:
MelliLisska
MelliLisska
08.09.2020 20:17
Решение в прикрепленном файле.

Ввод -вывод
5 12
6
7
8
9
10
длина отрезка: 3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота