Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
valentinadeva2p0arnh
13.01.2021 00:20 •
Информатика
Паскаль procedure f(n: integer); begin if n < = 5 then begin f(n + 2); writeln (n); f(n + 3) end end чему равна сумма всех чисел, напечатанных на экране при выполнении вызова f(l)? (и как)
Показать ответ
Ответ:
foben1
03.10.2020 06:04
ответ: 13.
А получается он вот так:
procedure F(n:integer);
begin
Writeln('Вызов F(',n,')');
if n <= 5 then begin
F(n + 2);
writeln('Процедура вывела ',n);
F(n + 3)
end
end;
begin
f(1)
end.
Результат работы программы:
Вызов F(1)
Вызов F(3)
Вызов F(5)
Вызов F(7)
Процедура вывела 5
Вызов F(8)
Процедура вывела 3
Вызов F(6)
Процедура вывела 1
Вызов F(4)
Вызов F(6)
Процедура вывела 4
Вызов F(7)
0,0
(0 оценок)
Популярные вопросы: Информатика
Lenika2len
03.01.2021 23:51
Вычисли число строк в таблице, считая шапку таблицы. Число переменных в выражении — 2....
kitsrarr
28.07.2022 06:49
Задание 1. Построим таблицу истинности для выражения: F = (A v B) & (¬ A v ¬ B) 1. Определим количество строк =2n = 22+1 =5 (1 строка – это заголовок таблицы) 2. Определим...
Sonechka9youtobe
30.03.2021 16:09
УЧЕНЫЕ, ОТЛИЧНИКИ ....
romanilblockp08hg1
04.12.2022 11:57
Выполните требования для гоночного поля, на котором роботы движутся по линии: 1. Ипподром - .. 2. Какой должна быть зона для ходьбы робота -... 3. Размер и вес робота....
АниАпельсинка
28.05.2020 17:14
Интегрированная среда разработки - это программное обеспечение, содержащее основные инструменты разработчика, необходимые для написания и тестирования программного обеспечения....
Katya1143
25.02.2022 03:17
Определите, что будет напечатано в результате выполнения следующего алгоритма.var s,k: integer; begin s := 1; k := 0; while s 220 do begin s := s * 3; k := k + 1end; writeln(k);...
России5544
01.02.2022 09:07
Символьные строки. Определить каким по счету символом является буква “у” в символьной строке “Я люблю информатику”. Паскаль ...
саша4278
11.02.2023 21:44
Программирование на си робот может перемещаться в четырех направлениях( n- север, w - запад, s - юг, e - восток) и принимать пять цифровых команд : 0 - остановка, 1 - продолжать...
aregv
11.11.2020 09:18
Соедини термины со значением  Гистограмма Цветовые шкалы Соедини термины со значением Гистограмма Цветовые шкалы...
ramoxa
15.09.2022 08:08
На стороне AD c треугольника ABC отмечена точка D так, что AD=6, DC=10. площадь треугольника ABC= 48. Найдите площадь треугольника ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
А получается он вот так:
procedure F(n:integer);
begin
Writeln('Вызов F(',n,')');
if n <= 5 then begin
F(n + 2);
writeln('Процедура вывела ',n);
F(n + 3)
end
end;
begin
f(1)
end.
Результат работы программы:
Вызов F(1)
Вызов F(3)
Вызов F(5)
Вызов F(7)
Процедура вывела 5
Вызов F(8)
Процедура вывела 3
Вызов F(6)
Процедура вывела 1
Вызов F(4)
Вызов F(6)
Процедура вывела 4
Вызов F(7)