В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
КАНЯ1111111111
КАНЯ1111111111
26.09.2021 03:06 •  Информатика

Паскаль) ) напишите программу вычисления среднего модулей двух введенных с клавиатуры чисел. программа должна использовать цикл while do. условия выхода их цикла-значение числа, равное 999.

Показать ответ
Ответ:
Jirnyi
Jirnyi
22.06.2020 16:29
Var a,b,sg: real;
begin
readln(a);
readln(b);

a:=abs(a); b:= abs(b);
sg:= sqrt(a*b);

writeln(sg);
end.

Вот программа вычисления средней геометрической. Но про цикл не понял...
0,0(0 оценок)
Ответ:
alexandra189
alexandra189
22.06.2020 16:29
Program Zadacha;
Var a, b, i: Integer;
c: Real;
Begin
Write('a = ');
ReadLn(a);
Write('b = ');
ReadLn(b);
c := Sqrt(Abs(a) * Abs(b));
i := 0;
While i < 999 Do
i := i + 1;
WriteLn('Результат: ', c:5:2);
ReadLn;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота