В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ZloYDedyskA
ZloYDedyskA
17.10.2021 11:34 •  Информатика

Паскаль напишите программу, которая выводит на экран массив в в одну строку и определяет количество четных и количество нечетных элементов.

Показать ответ
Ответ:
878v878
878v878
08.10.2020 09:52
PascalABC.NET 3.3.5, сборка 1650 от 01.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var b:=ArrRandom(ReadInteger('n='),-50,50); b.Println;
  Writeln('Четных элементов ',
      b.Where(t->t.IsEven).Count,
      ', нечетных ',
      b.Where(t->t.IsOdd).Count)
end.

Пример
n= 20
-18 -1 48 -31 -18 -34 -42 20 -30 14 -16 45 50 0 -18 39 45 19 -10 16
Четных элементов 14, нечетных 6
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота