В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Dzoker34
Dzoker34
28.05.2023 16:33 •  Информатика

Паскаль! напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, последняя цифра которых равна а и все число делится на в. последовательность чисел заканчивается числом 0. числа а и в вводятся до цикла. (должен быть цикл while)

Показать ответ
Ответ:
NiKoOl18
NiKoOl18
05.10.2020 23:24
Var
  a, b, num, sum: integer;

begin
  readln(a, b);
  readln(num);
  while num <> 0 do
  begin
    if (num mod 10 = a) or (num mod b = 0) then
      sum := sum + num;
    readln(num);
  end;
  writeln(sum)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота