В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Chalmers1998
Chalmers1998
01.05.2023 07:04 •  Информатика

Паскаль
Напишите программу, которая проверяет правильность ПОВТОРНОГО ввода пароля.

Показать ответ
Ответ:
Grizzly23
Grizzly23
07.12.2020 12:46

я бы хотел съездить в город бийск, потому что там красиво, особенно в алтайских горах. горы почти достают до неба. внизу они зеленые от растущего вокруг леса. выше — светлые, а верхушки — совсем бело-голубые. я бы хотел побывать на священном ручье, который несет чистую ледяную воду с гор в реку катунь. недалеко от ручья есть дерево желаний. каждый может подойти к нему, загадать желание и привязать к его ветвям ленточку. и красуется это дерево, как разноцветная ёлка. еще я бы хотел побывать на том месте, где сливаются реки бия и катунь, образуя реку обь. и с приятными воспоминаниями и впечатлениями вернуться домой.

 

ich möchtein die stadtgehen, weil esbijskist sehr schön,vor allem in deraltai-gebirge.diebergehat fastbis zumhimmel.an der unterseitesind siegrünauswachsen rund umden wald.above -licht, und dietop -nur dieblau und weiß.ich möchteden heiligenbach, derein reinesgletscherwasseraus den bergendes flusseskatunist, zu besuchen.in der nähe desbachesgibt es einen baumwünsche.jeder kannkommenund sich etwas wünschenund binden sie esan die zweigedes bandes.undschmückten denbaum alsbunten baum.ich möchte auchan die stelle, wo die flüssekatunundbiya,bildenden flussobbesuchen.undmit angenehmenerinnerungen und erfahrungenwieder nach hause.

0,0(0 оценок)
Ответ:
maxmaxibon11
maxmaxibon11
01.02.2022 20:21
Const n=20;
var 
a,b:array[1..n] of integer;
i,j,k,m,c:integer; 
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
  a[i]:=random(51)-25;
  write(a[i]:5);
 end;
writeln;
j:=0;
for i:=1 to n do
 if a[i]<0 then begin j:=j+1; b[j]:=a[i]; end;
m:=j;
for k := 1 to m-1 do
  for i := 1 to m-k do
     if (b[i]<b[i+1]) then 
       begin
       c:=b[i]; b[i]:=b[i+1]; b[i+1]:=c;
       end;
writeln('Вс массив:');
for i:=1 to m do write(b[i]:5);
writeln;
j:=0;
for i:=1 to n do
 if a[i]<0 then begin j:=j+1; a[i]:=b[j]; end;
writeln('Полученный массив:');
for i:=1 to n do write(a[i]:5);
writeln;
end.

Пример:
Исходный массив:
  -15   -8   -6  -13   15   24    5   -2   14   -1   19   -2   -7   -8  -23   20   -2    7   -2  -10
Вс массив:
   -1   -2   -2   -2   -2   -6   -7   -8   -8  -10  -13  -15  -23
Полученный массив:
   -1   -2   -2   -2   15   24    5   -2   14   -6   19   -7   -8   -8  -10   20  -13    7  -15  -23
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота