В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Djjhsb
Djjhsb
03.10.2022 11:04 •  Информатика

Паскаль! напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221).

Показать ответ
Ответ:
Penguinunicirn
Penguinunicirn
04.10.2020 04:19
Var
  n,i:integer;
  s:string;
begin
  Write('Введите натуральное число: '); Read(n);
  Str(n,s);
  for i:=2 to Length(s) do
    if s[i]=s[i-1] then begin
      Writeln('Пара одинаковых цифр-соседей ',s[i]);
      Exit
      end;
  Writeln('В числе нет цифр, имеющих таких же соседей')
end.

Пример
Введите натуральное число: 375422453
Пара одинаковых цифр-соседей 2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота