В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Птичка220903
Птичка220903
12.05.2022 16:19 •  Информатика

Паскаль написать программу которая для прямоугольной целочисленной матрицы 3×4 определяет номер самого левого столбца содержащего только положительные элементы. если такого столбца нет выводится сообщение

Показать ответ
Ответ:
mari200423
mari200423
07.09.2020 19:33
Const m = 3;
n = 4;
var a: array[1..m, 1..n] of integer;
b: array[1..n] of integer;
i,j,k,maxm:integer;
begin
  for i:=1 to m do begin
    for j:=1 to n do begin
      write('A[',i,',',j,']= ');
      readln (a[i,j]);
      if a[i,j]<=0 then b[j]:=-1;
    end;
  end;
 
  for i:=1 to n do begin
    if b[i]=0  then begin
      writeln('Столбец №',i,' Все положительные');
      break;
     end
     else
      if i=n then writeln('Таких столбцов не было');
    end;
  for i:=1 to m do begin
    for j:=1 to n do write(a[i,j]:5);
    writeln;
  end;
end.

Тестовое решение:
A[1,1]= 7
A[1,2]= 2
A[1,3]= 1
A[1,4]= -9
A[2,1]= -2
A[2,2]= 2
A[2,3]= 4
A[2,4]= 1
A[3,1]= 7
A[3,2]= 2
A[3,3]= 3
A[3,4]= 1
Столбец №2 Все положительные
    7    2    1   -9
   -2    2    4    1
    7    2    3    1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота