В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
санеке
санеке
15.05.2022 08:08 •  Информатика

Паскаль или с++. новые роботы для создания нового робота необходимо x блоков с маркировкой ‘1’, y блоков памяти с маркировкой ‘2’ и z блоков ввода/вывода с маркировкой ‘3’. всего на складе n блоков. главный робот составил список всех блоков на складе. сколько новых роботов можно создать из имеющихся на складе блоков? формат входных данных в первой строке вводятся 4 числа n, x, y, z. во второй строке вводятся n чисел. все числа целые и не превышают 1000. формат результата одно число – ответ на . примеры входные данные результат работы 15 2 1 3 1 1 2 3 3 3 1 2 3 1 2 3 1 2 3 2

Показать ответ
Ответ:
david528
david528
03.11.2022 05:29

Язык Python 3.7

Думаю по коду должно быть все понятно , но если возникнут вопросы

постараюсь ответить

1)  

x = int (input())  

print(6*x*(x+2)-(x+4))

2)

x = int (input())

if x>0:  

   print((x**2)+(2*x))

else :    

   print(x-3)

3)

x=13

i=10 #Счетчик

while i<100:               #Цикл будет выполнятся пока i меньше 100

   print(x*i)

   i=i+1                        #Обновление счетчика

4)

x=0                               #Создание счетчика

while x<21:  

   print(9*(x**2)+6*x)

   x=x+2                      #Обновление счетчика

5)

x1=int(input())

x2=int(input())

x3=int(input())

if x1==x2 and x2==x3:

   print("Треугольник равносторонний")

else:

   print("Треугольник не равносторонний")

6)

a=int(input())                   # Ввод значения

for i in range (1,a+1):       #Создание цикла , в котором перебираются                      

      print(i**2)                   числа   от 1 до a                      

   

0,0(0 оценок)
Ответ:
dfrt2
dfrt2
12.02.2020 15:35

1) Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в N-ю степень, где N - количество цифр в числе, равна самому числу. Напримерт153=1^3 5^3 3^3. Найдитетвсе трехзначныеии четырехзначныеичисла Армстронга

var a,b,c,d,a2:integer;

begin

for a:=100 to 9999 do begin

d:=0;

a2:=a;

while (a2 <> 0) do begin

b:= a2 mod 10;

a2:= a2 div 10;

if a<1000 then c:= (b*b*b)

else c:=(b*b*b*b);

d:= d+c;

end;

if (a = d) then writeln('число армстронга ==> ', a);

end;

end.

2)Авmoморфные числа. Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата. Например: 25 и 625. Напишите программу, которая вводит натуральное число N и выводит на акран все автоморфные числа, не превосходящие N.

var n,i,l:integer; s1,s2:string;

begin

write('n = '); readln(n);

for i:=1 to n do

begin

str(i,s1);

l:=length(s1);

str(i*i,s2);

if s1=copy(s2,length(s2)-l+1,l) then writeln(i,' ',i*i);

end;

end.

3)Модифицированный алгоритм Евклида для вычисления наибольшего общего делителя двух натуральных чисел, формулируется так: нужно заменять большее число на остаток от деления большего на меньшее до тех пор, пока остаток не станет равно нулю; тогда второе число и есть НОД. Напишите программу, которая реализует этот алгоритм.

var a,b,nod,k:integer;

begin

readln(a,b);

k:=0;

while (a<>0)and(b<>0) do

begin

if a>b then a:=a mod b else b:=b mod a;

k:=k+1;

end;

nod:=a+b;

writeln(nod,' ',k);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота