В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
12345678йцуке
12345678йцуке
19.12.2022 10:40 •  Информатика

Паскаль доделать вклад в банке составляет x рублей. ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. каждый год сумма вклада становится больше. определите, через сколько лет вклад составит не менее y рублей. входные данные программа получает на вход три натуральных числа: x, p, y. выходные данные программа должна вывести одно целое число. program u1; var x, p ,s,n: integer; y: real; begin read(x); read(p); read(y); s: =0; s: = x +(x*p)div 100; n: = 1; while (s < y) do begin s : = s +((s*p)div 100); n: = n + 1; end; writeln (n); readln; end. здесь где-то есть недоработка.

Показать ответ
Ответ:
Mamiksem
Mamiksem
05.10.2020 02:20
Program u1;
var 
x, p ,y, s, n: integer;
begin
readln(x,p,y); 
s:=x;
n:= 0; 
while (s < y) do 
begin 
s := s+trunc((s*p)/100); 
n:= n+1; 
end; 
writeln(n);
end.

Пример:
100 10 500
18
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота