В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
пидрила5
пидрила5
27.01.2022 20:08 •  Информатика

Паскаль: дан список фамилий учащихся (абсолютно любой). определите количество фамилий, начинающихся с буквы "М" (или другой любой буквы), выведите эти фамилии в файл.​

Показать ответ
Ответ:
Учительнотупой
Учительнотупой
26.10.2021 13:15

#include <iostream>

#include <cstdlib>

#include <ctime>

#include <vector>

#include <algorithm>

using namespace std;

bool myfunction (int i,int j) { return (i<j); } // comparator

int main() {

setlocale(0, "");

srand(time(0));

float u(0.0f), v(0.0f), w(0.0f); //суточный рацион коровы, состоящий из сена, силоса и комбикорма

float k(0.0f); // колво голов в ъозяйстве

float s(0.0f), t(0.0f), f(0.0f); // сколько осталось сена, силоса и комбикорма

float percP(0.0f); //  в день погибает % коров

float percQ(0.0f), percR(0.0f), percT(0.0f); //  в день сгнивает сена, силоса и комбкорма %

int dayCounter = 0;

cout << "Сена в день: ";

cin >> u;

cout << "Силоса в день: ";

cin >> v;

cout << "Комбикорма в день: : ";

cin >> w;

cout << "Всего коров: ";

cin >> k;

cout << "Осталось сена: ";

cin >> s;

cout << "Осталось силоса: ";

cin >> t;

cout << "Осталось комбикорма: ";

cin >> f;

cout << "Сколько % в день погибает коров: ";

cin >> percP;

cout << "Сколько % пропадает сена: ";

cin >> percQ;

cout << "Сколько % пропадает силоса: ";

cin >> percR;

cout << "Сколько % пропадает комбикорма: ";

cin >> percT;

while(1) {

if(s<u) {

cout << "Кончилось сено. Прожито дней: " << dayCounter << ". Осталось коров: " << k;

 break;

}

if(t<v) {

 cout << "Кончился силос. Прожито дней: " << dayCounter << ". Осталось коров: " << k;

 break;

}

if(f<w) {

 cout << "Кончился комбикорм. Прожито дней: " << dayCounter << ". Осталось коров: " << k;

 break;

}

cout << "День:: " << dayCounter << "    ";

cout << "Осталось коров: " << static_cast<int>(k) << endl;

// кормим коров

s-=u;

t-=v;

f-=w;

//конец дня. Заного считаем припасы и коров.

k=k/100*(100-percP);

s=s/100*(100-percQ);

t=t/100*(100-percR);

f=f/100*(100-percT);

++dayCounter;

}

system("pause");

}

0,0(0 оценок)
Ответ:
Filindenis
Filindenis
09.06.2021 17:20

По условию текст написан в КОИ-8, где 1 символ весит 8 бит.

Всего тест занимает 8 Кбайт

Переведем 8 Кбайт в биты: 8 Кбайт = 65536 бит

Текст занимает 8 Кбайт или 65536 бит

Теперь узнаем количество символов в тексте: разделим 65536 бит на 8 бит, так как 1 символ = 8 бит: 65536 бит : 8 бит = 8192‬

В тексте всего 8192‬ символа.

По условию страница содержит 32 строки по 40 символов, всего символов содержит: 32 * 40 = 1280‬. (1 страница может вместить 1280‬ символов)

Теперь найдем количество необходимых листов для записи нашего текста: 8192‬  / 1280‬ = 6,4 листа.

Так как наш текст не поместится на 6 листах, то возьмем еще 1 лист и,в итоге, получим 7 листов

ответ: 7 листов

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота