В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
timkoa
timkoa
13.04.2020 23:17 •  Информатика

ПАСКАЛЬ Дан одномерный массив A[10]. Элементы массива – это случайные числа большие 0.
Написать программу, которая будет находить произведение элементов массива,
лежащих в интервале [20, 70].

Показать ответ
Ответ:
JackKalibr
JackKalibr
23.08.2020 20:14

var i,s: integer;

begin

s:=1;

randomize();

for i:=1 to 10 do

 begin

 A[i]:=random(100);

 write(A[i],' ');

 if (A[i]>=20) and (A[i]<=70) then

 s:=s*A[i];

 end;

writeln();

writeln('Произведение элементов массива: ',s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота