В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Brakorenko88
Brakorenko88
23.02.2023 12:14 •  Информатика

Паскаль абс.составить программу для решения следующей : известный пират флинт положил некоторую сумму s в банк под 3% годовых. выведите на экран, через сколько лет сумма превысит 1,5s. начальное значение s вводится с клавиатуры. решать через while

Показать ответ
Ответ:
TTLoXoIMalchik
TTLoXoIMalchik
10.10.2020 02:50

program flint;

var s, s2, y: real;

begin;

readln(s);

s2 := s * 1.5;

while s < s2 do begin;

s := s * 1.03;

y := y + 1;

end;

writeln(y)

end.

0,0(0 оценок)
Ответ:
йщз
йщз
10.10.2020 02:50

Program n_1;

var s, m: real; n:integer;

begin

 read(s);

 n:=0; m:=s;

 while (m<=1.5*s) do begin

   m:=m*1.03;

   n:=n+1;

 end;

 writeln(n);

end.

Честно говоря, решение тут вообще не зависит от S. Всегда выводится одно и то же число - 14

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота