В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
a01065699799
a01065699799
16.02.2020 02:45 •  Информатика

ПАСКАЛЬ АБС 8 КЛАСС! Составьте программу, которая запрашивает время в часах (0, 3, 6, 9, 12, 15, 18, 21, 24) и рисует часы с показаниями часовой
стрелки (рис. 3.14).


ПАСКАЛЬ АБС 8 КЛАСС! Составьте программу, которая запрашивает время в часах (0, 3, 6, 9, 12, 15, 18,

Показать ответ
Ответ:
AnnaNazar07
AnnaNazar07
19.03.2021 00:01

PascalABC, проще уже некуда

Объяснение:

uses graphABC;

var  h: integer;

begin

 SetWindowSize(400, 400);

 Write('Введите время в часах(0, 3, 6, 9, 12, 15, 18, 21, 24): ');

 ReadLn(h);

 SetPenWidth(2);

 Circle(200, 200, 100);

 Line(200, 200, 200, 103);

 SetPenWidth(5);

 case h of

   0, 12, 24: Line(200, 200, 200, 105);  

   3, 15: Line(200, 200, 295, 200);  

   6, 18: Line(200, 200, 200, 295);  

   9, 21: Line(200, 200, 105, 200);  

 end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота